Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#3540 closed enhancement (fixed)

Revert zoom to the initial value

Reported by: humitos Owned by: erikos
Priority: Low Milestone:
Component: Browse Version: Unspecified
Severity: Unspecified Keywords: patch
Cc: garycmartin, godiard, manuq, humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by humitos)

When you are reading a webpage and you want to increase the zoom level you can pres Ctrl + + and keep reading it. Some time later you want to go back to the original zoom value (the first value that it had when you opened the page) but there is no way to do it.

It would be good to add this functionality with the hotkey Ctrl + = as Epiphay does:

Attachments (3)

0001-Revert-zoom-with-the-original-value.patch (3.0 KB) - added by humitos 11 years ago.
0001-Revert-zoom-with-the-original-value-SL-3540.patch (3.1 KB) - added by humitos 11 years ago.
0001-Revert-zoom-with-the-original-value-SL-3540.2.patch (3.0 KB) - added by manuq 10 years ago.
Changed the tooltip string to "Actual size" as discussed in the design thread. Renamed zoomequal variable to zoom_original so we don't add another word for it (use the same as the constant and the icon name).

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by humitos

  • Description modified (diff)

comment:2 Changed 11 years ago by humitos

  • Description modified (diff)

comment:3 Changed 11 years ago by humitos

OK. Laberynth has a similar option and it's implemented with Control + 0. So, I think because of consistency we should implement this with Control + 0.

comment:4 Changed 11 years ago by erikos

  • Cc garycmartin added
  • Milestone changed from Unspecified by Release Team to 0.98

comment:5 Changed 10 years ago by humitos

  • Cc godiard manuq humitos added
  • Keywords patch added

CCing Gonzalo and Manuq, maybe they can take a look and apply this patch.

comment:6 Changed 10 years ago by erikos

Firefox uses as well ctrl+0 and ctrl+0 works in Epiphany as well, so the shortcut sounds good.

Changed 10 years ago by manuq

Changed the tooltip string to "Actual size" as discussed in the design thread. Renamed zoomequal variable to zoom_original so we don't add another word for it (use the same as the constant and the icon name).

comment:7 Changed 10 years ago by manuq

  • Resolution set to fixed
  • Status changed from new to closed

Pushed as 02aa9d5b after eriko's ACK with the small changes described above.

comment:8 Changed 9 years ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.