Opened 9 years ago

Closed 8 years ago

#3128 closed defect (obsolete)

Browse I18n error

Reported by: cjl Owned by: lucian
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

The POT generating script is throwing a warning flag on browse

downloadmanager.py:344: warning: 'msgid' format string with unnamed arguments cannot be properly localized:

The translator cannot reorder the arguments.
Please consider using a format string with named arguments,
and a mapping instead of a tuple for the arguments.

Specifically this string

#: downloadmanager.py:344
#, python-format
msgid ""
"Downloading %s from \n"
"%s."
msgstr ""

Because this contains two %s variables and because the object-subject ordering in different languages can be different, these should be changed to named variables (adding whatever names would be appropriate.

"Downloading %(page)s from \n"
"%(website)s."

This will allow Localizers to unambiguuosly re-order these variable substitutions in their language's syntax.

Change History (2)

comment:1 Changed 9 years ago by cjl

  • Component changed from untriaged to Browse
  • Owner set to lucian

comment:2 Changed 8 years ago by humitos

  • Resolution set to obsolete
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.