Opened 12 years ago

Closed 12 years ago

#31 closed defect (obsolete)

Journal: USB stick does not register when inserted.

Reported by: mungewell Owned by: tomeu
Priority: major Milestone:
Component: journal Version: 0.82.x
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Resolved

Description

I had a couple of times over the weekend when a working USB stick became 'un-registerable', it would not show itself at the bottom of the journal page.

I had the following error in the journal log
--
'DatabaseLockError: Unable to acquire database write lock on /media/LEXAR/.olpc.store/index'
--

On mounting the drive read/write and erasing the directory '.olpc.store' and unmounting/removing the USB stick it became useable again.

I think that this may be caused by unplugging a mounted USB stick without umounting.... probably a likely event with school children.

Change History (5)

comment:1 Changed 12 years ago by tomeu

  • Component changed from sugar to journal
  • Owner changed from marcopg to tomeu

comment:2 Changed 12 years ago by tomeu

  • Version set to 0.82.x

comment:3 Changed 12 years ago by gregdek

  • Bug Status set to Needinfo
  • Distribution/OS set to Unspecified
  • Severity set to Blocker

Great bug. Some more info would be very helpful here. Could you help us further isolate to a single reproducible case? Some info that would be helpful:

  1. Is this on an XO only, or does it happen on non-XOs as well?
  1. Can you reliably make it happen with the same error?
  1. The theory of "unplugging and then replugging" -- have you tried it, and does that always create the same error?

If you can give us one series of steps that will *always* give this error, that will be much appreciated. Thanks for reporting.

comment:4 Changed 12 years ago by gregdek

  • Severity changed from Blocker to Major

Also, I'm going to set severity of this to "Major," since if this is a problem, I'd call it major myself.

comment:5 Changed 12 years ago by erikos

  • Bug Status changed from Needinfo to Resolved
  • Resolution set to obsolete
  • Status changed from new to closed

Unlikely that we have the ressources to fix this. And it looks like we do not even have a way to reproduce this. This has no effect on 0.84.

Sorry :/

Note: See TracTickets for help on using tickets.