Opened 11 years ago

Closed 11 years ago

#2980 closed defect (fixed)

installing activities broken due to upstream jhbuild requiring DESTDIR support

Reported by: andi_g Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Blocker Keywords:
Cc: Distribution/OS:
Bug Status: New

Description

Traceback (most recent call last):

File "./sugar-jhbuild", line 62, in <module>

sys.exit(main.main(base_dir, sys.argv[1:]))

File "/home/andi/dev/tmp/sugar-jhbuild/sjhbuild/main.py", line 111, in main

rc = jhbuild.commands.run(command, config, args, help=lambda: jhbuild.main.print_help(parser))

File "/home/andi/dev/tmp/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 123, in run

return cmd.execute(config, args, help)

File "/home/andi/dev/tmp/sugar-jhbuild/jhbuild/jhbuild/commands/init.py", line 52, in execute

return self.run(config, options, args, help)

File "/home/andi/dev/tmp/sugar-jhbuild/jhbuild/jhbuild/commands/base.py", line 274, in run

module_set = jhbuild.moduleset.load(config)

File "/home/andi/dev/tmp/sugar-jhbuild/jhbuild/jhbuild/moduleset.py", line 352, in load

ms.modules.update(_parse_module_set(config, uri).modules)

File "/home/andi/dev/tmp/sugar-jhbuild/jhbuild/jhbuild/moduleset.py", line 450, in _parse_module_set

inc_moduleset = _parse_module_set(config, inc_uri)

File "/home/andi/dev/tmp/sugar-jhbuild/jhbuild/jhbuild/moduleset.py", line 467, in _parse_module_set

repositories, default_repo)

File "/home/andi/dev/tmp/sugar-jhbuild/jhbuild/jhbuild/modtypes/init.py", line 61, in parse_xml_node

return parser(node, config, uri, repositories, default_repo)

File "/home/andi/dev/tmp/sugar-jhbuild/sjhbuild/bundlemodule.py", line 60, in parse_bundle

supports_non_srcdir_builds = supports_non_srcdir_builds)

TypeError: init() got an unexpected keyword argument 'suggests'

Change History (2)

comment:1 Changed 11 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Distribution/OS Fedora deleted
  • Severity changed from Unspecified to Blocker

Thanks for the report! Please include the full invocation the next time, this makes reproducing the issue easier.
Upstream seems to be hacking on jhbuild quite a bit lately, breaking sugar-jhbuild repeatedly as a consequence. I've fixed the exact issue you've reported, only to hit the next one:

[...]
Install locale/ml/LC_MESSAGES/org.laptop.Chat.mo to /home/sascha.silbe/sugar-jhbuild/install/share/locale/ml/LC_MESSAGES/org.laptop.Chat.mo.
Install locale/mr/LC_MESSAGES/org.laptop.Chat.mo to /home/sascha.silbe/sugar-jhbuild/install/share/locale/mr/LC_MESSAGES/org.laptop.Chat.mo.
Install locale/te/activity.linfo to /home/sascha.silbe/sugar-jhbuild/install/share/sugar/activities/Chat.activity/locale/te/activity.linfo.
*** Error during phase install of chat: Module failed to install into DESTDIR u'/home/sascha.silbe/sugar-jhbuild/install/_jhbuild/root-chat-broken' *** [1/1]

This is because upstream decided to fail hard on modules that don't support DESTDIR (Gnome#654592) and sugar.activity.bundlebuilder doesn't support DESTDIR yet (SL#2947).

comment:2 Changed 11 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from bug in sugar-jhbuild to installing activities broken due to upstream jhbuild requiring DESTDIR support

Once I figured out what exactly I needed to do, the patch was trivial. Fixed by 5923202.

Note: See TracTickets for help on using tickets.