Opened 8 years ago

Closed 8 years ago

#2878 closed defect (fixed)

python-beautiful soup dependency lacking on dextrose (was:Read-89 does not start on Sugar 0.88)

Reported by: RafaelOrtiz Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Dextrose Version: Git as of bugdate
Severity: Unspecified Keywords: dx3
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Traceback

1307108018.499219 ERROR root: Traceback (most recent call last):
  4   File "/home/rafael/src/sugar/.sweets/local/../../bin/sugar-activity", line 21, in <module>
  5     main.main()
  6   File "/home/rafael/src/sugar-toolkit/src/sugar/activity/main.py", line 118, in main
  7     module = __import__(module_name)
  8   File "/home/rafael/Activities/Read.activity/readactivity.py", line 54, in <module>
  9     import epubadapter
 10   File "/home/rafael/Activities/Read.activity/epubadapter.py", line 4, in <module>
 11     import epubview
 12   File "/home/rafael/Activities/Read.activity/epubview/__init__.py", line 23, in <module>
 13     from epubview import _View as EpubView
 14   File "/home/rafael/Activities/Read.activity/epubview/epubview.py", line 25, in <module>
 15     import BeautifulSoup
 16 ImportError: No module named BeautifulSoup

Change History (7)

comment:1 Changed 8 years ago by RafaelOrtiz

  • Summary changed from Read-86 does not start on Sugar 0.88 to Read-89 does not start on Sugar 0.88

comment:2 Changed 8 years ago by RafaelOrtiz

This looks as a regression, patch proposed on mail list.

comment:3 Changed 8 years ago by RafaelOrtiz

  • Version changed from Unspecified to Git as of bugdate

comment:4 Changed 8 years ago by erikos

  • Owner changed from sayamindu to godiard
  • Status changed from new to assigned

comment:5 Changed 8 years ago by godiard

Replied in the list too.

We can't remove BeautifulSoup from jobs.py, because is used to search.

comment:6 Changed 8 years ago by RafaelOrtiz

  • Component changed from Read to Dextrose
  • Keywords dx3 added
  • Summary changed from Read-89 does not start on Sugar 0.88 to python-beautiful soup dependency lacking on dextrose (was:Read-89 does not start on Sugar 0.88)

This is python-beautifulsoup lacking on the o.s, that was preventing read to start we should have it on dextrose build.

changing component and summary

comment:7 Changed 8 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from assigned to closed

Tested and fixed on Dx3. (test builds).

Note: See TracTickets for help on using tickets.