Opened 12 years ago

Closed 12 years ago

#25 closed defect (obsolete)

Journal hardcodes USB mounting as UID=500

Reported by: morgs Owned by: tomeu
Priority: major Milestone:
Component: Sugar Version: 0.82.x
Severity: Blocker Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Sucrose 0.82.x

https://bugs.launchpad.net/ubuntu/+source/sugar-journal-activity/+bug/297479

It appears that there is a hard coded UID for mounting USB flash drives.

In Journal.activity/volumesmanager.py
--
MOUNT_OPTION_UID = 500
--

This should use the UID of the actual user on the system who is running Sugar. Note: there may be more than one user active in a multiseat/thin client system.
On a one user Ubuntu system, the UID of the user is 1000. On a multi user system, the UIDs will vary.

Change History (8)

comment:1 Changed 12 years ago by mungewell

The same code has be moved to:
[sugar] / src / jarabe / model / volume.py

Although there is a note in [sugar] / src / jarabe / journal / volumestoolbar.py that the mounting of USB drives has been disabled for now.

comment:2 Changed 12 years ago by mungewell

Brief reading around this subject... might ConsoleKit and PolicyKit be useful in this situation, if you want to add the dependencies.

Otherwise the volumestoolbar should use the current UID and hope that there is no-one else active on the machine.

comment:3 Changed 12 years ago by marcopg

Yeah sounds like we should be using CK here.

comment:4 Changed 12 years ago by tomeu

  • Owner changed from marcopg to tomeu
  • Status changed from new to assigned

comment:5 Changed 12 years ago by tomeu

  • Version set to 0.82.x

That's only 0.82, in 0.83 we are already using GIO for that and I tested as working on non-XOs.

comment:6 Changed 12 years ago by gregdek

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Resolution set to fixed
  • Severity set to Blocker
  • Status changed from assigned to closed

Since this is fixed in the current release, and since we do not currently have manpower to backport fixes to older releases, we are closing this bug.

comment:7 Changed 12 years ago by gregdek

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed 12 years ago by gregdek

  • Resolution set to obsolete
  • Status changed from reopened to closed

Closing properly as "obsolete".

Note: See TracTickets for help on using tickets.