Opened 9 years ago

Closed 8 years ago

#2324 closed enhancement (fixed)

add copy toolbar to abacus

Reported by: walter Owned by: walter
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Abacus Version: Unspecified
Severity: Unspecified Keywords: sugar-love
Cc: smparrish, tonyforster Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

After calculations, results should be available to the clipboard

Also, numbers should be able to be pasted to the abacus and displayed.

Change History (7)

comment:1 Changed 8 years ago by smparrish

  • Cc smparrish added

comment:2 Changed 8 years ago by smparrish

  • seeta_dev set to Shanjit

comment:3 Changed 8 years ago by walter

Please note that I recently pushed to git a patch to allow typing values into to set the abacus to a particular number. Needs a bit more work, but it should be useful if you want to implement 'paste'.

http://git.sugarlabs.org/projects/abacus/repos/mainline/commits/c76e411c2c50224288f2cbe783c30e8ae0821cbd

comment:4 Changed 8 years ago by walter

Please refer to #2323 for some ideas as to what would need to be done for this ticket.

comment:5 Changed 8 years ago by tonyforster

  • Cc tonyforster added

So you will be able, for example, to convert a decimal number to a binary representation? What about not zeroing the abacus when you change scales as an easy alternative for these conversions? What about pasting fractions into integer abacuses? What when a number has 2 different representations on the one abacus?

comment:6 Changed 8 years ago by walter

So you will be able, for example, to convert a decimal number to a binary representation?

Yes. In the version currently in git, you can type numbers (on the bar where the results are displayed) and whatever abacus you are using will display those results.

What about not zeroing the abacus when you change scales as an easy alternative for these conversions?

Do you have the abacus start with the value of whatever abacus you had previously been using?

What about pasting fractions into integer abacuses? What when a number has 2 different representations on the one abacus?

At present, if you type in a fraction on an integer abacus, you only get the whole number part. If you type a number too large to fit on an abacus, you get a somewhat random result. (I need to do some bounds checking.)

The most "efficient" representation is used when more than one is available (i.e., maximizing the use of top beads and beads towards the left).

There is currently a "bug" regarding inputing some fractions: for example, inputing 1/3 will not result in a 1/3 bead being selected, since internally I make a decimal approximation. I need to think about the best way to handle this.

comment:7 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.