Opened 9 years ago

Closed 6 years ago

#2285 closed defect (obsolete)

sugar-emulator's window title is 'xephyr on…' instead of sugar

Reported by: lfaraone Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.88.x
Severity: Unspecified Keywords: r!
Cc: dfarning Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

Forwarded from https://launchpad.net/bugs/617805:

"""
To reproduce the bug follow these steps-

  1. Run sugar emulator.
  2. Check the bottom bar of window.

Resolution: It should display 'Sugar'.
"""

I'm also including a patch by Ishan that fixes the issue.

Attachments (2)

2285.patch (585 bytes) - added by lfaraone 9 years ago.
2285-1.patch (1.1 KB) - added by lfaraone 9 years ago.
Revised patch. (authored by Ishan Bansal)

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by lfaraone

comment:1 Changed 9 years ago by sascha_silbe

I would prefer a title like "Sugar inside Xephyr" or "Sugar in a window". There's a lot of confusion between the different ways to build (distro packages or sugar-jhbuild) and run (natively or sugar-emulator) Sugar so we need to be clear about what is what. A lot of people even seem to think that sugar-emulator emulates the XO-1 hardware in some way (no doubt due to the name).
If you include menu entries for running Sugar in the Debian/Ubuntu distro packages, please take the above into account (e.g. name it "Run Sugar in a window").

As to the patch, it would be nice to have the two new parameters on a single line as they belong together.
E.g.:

    cmd += ['-title', 'Sugar inside Xephyr']

Changed 9 years ago by lfaraone

Revised patch. (authored by Ishan Bansal)

comment:2 Changed 9 years ago by tomeu

  • Keywords r! added; r? removed

+1 to "Sugar in a window" as Xephyr is an implementation details that the user doesn't need to know about and may change in the future.

Also note that you need to put that string between _() so it's included for translation.

And finally, please create the patch with git format-patch.

comment:3 Changed 9 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 follow-up: Changed 8 years ago by bernie

  • Resolution fixed deleted
  • Status changed from closed to reopened

This change disables the informative titlebar message "ctrl+shift grabs/releases mouse and keyboard", without which the emulator is unusable.

I looked at the Xephyr code: after setting a user title, there's no way to make the message toggle automatically. Therefore, I recommend reverting this patch.

comment:5 in reply to: ↑ 4 Changed 8 years ago by sascha_silbe

Replying to bernie:

This change disables the informative titlebar message "ctrl+shift grabs/releases mouse and keyboard", without which the emulator is unusable.

I looked at the Xephyr code: after setting a user title, there's no way to make the message toggle automatically. Therefore, I recommend reverting this patch.

We should file a ticket against Xephyr and work around it by adding the above message to the title.

comment:6 Changed 6 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.