Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2270 closed defect (invalid)

sugar-emulator crashes on startup (jhbuild)

Reported by: bernie Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: untriaged Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Needinfo

Description

Tested on Fedora 14, using jhbuild sources as of today. This may or may not be related to #2269.

After a few seconds, the emulator quits, leaving this error in shell.log:

Traceback (most recent call last):
  File "/home/bernie/src/sugar/sugar-jhbuild/install/bin/sugar-session", line 275, in <module>
    main()
  File "/home/bernie/src/sugar/sugar-jhbuild/install/bin/sugar-session", line 247, in main
    start_ui_service()
  File "/home/bernie/src/sugar/sugar-jhbuild/install/bin/sugar-session", line 82, in start_ui_service
    ui_service.start()
AttributeError: 'UIService' object has no attribute 'start'
1283348946.599232 DEBUG root: _cleanup_temp_files

Change History (3)

comment:1 Changed 9 years ago by tomeu

  • Bug Status changed from Unconfirmed to Needinfo

Are you sure you don't have old sources around? Such line does not exist in sugar since some releases ago:

http://git.sugarlabs.org/projects/sugar/repos/mainline/blobs/master/bin/sugar-session#line81

comment:2 Changed 9 years ago by bernie

  • Resolution set to invalid
  • Status changed from new to closed

Damn, the sugar module was being skipped from jhbuild:

*** module sugar not built due to non buildable GConf-dbus *** [8/22]
*** module meta-glucose not built due to non buildable sugar *** [9/22]
*** Installing read *** [10/22]
python setup.py install --prefix /home/bernie/src/sugar/sugar-jhbuild/install

When can we kill the f$>#@?ng GConf-dbus from the default jhbuild run? It has caused enough waste of time for its little usefulness.

comment:3 Changed 9 years ago by bernie

After fixing this, I got to #2269.

Note: See TracTickets for help on using tickets.