Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#2235 closed enhancement (fixed)

improvements to spiral home view

Reported by: walter Owned by: walter
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: r?
Cc: garymartin, tomeu, mtd Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Closing #2143 and opening this ticket to incorporate the modifications recommended by the design team.

The new patches are divided into two parts:

(1) improvements to the basic ring layout that get inherited by all of its subclasses
(2) introduction of a new class that incorporates the spiral int the ring.

Note that in the 2nd patch in order to have the ring that morphs into a spiral become the new default without having to modify the user's .gconf settings or favoriteview.py, I have renamed the RingLayout class to BasicRingLayout and use the name RingLayout for the spiral and I use the ring-layout key for the new class.

Attachments (3)

0001-updated-Ring-view-layout-details.patch (7.8 KB) - added by walter 10 years ago.
first, apply layout changes to existing Ring
0001-add-spiral-to-ring-layout-as-number-of-icons-increas.patch (8.8 KB) - added by walter 10 years ago.
next, add spiral enhancement as new default
0001-a-more-succint-approach-to-the-spiral-morph.patch (12.7 KB) - added by walter 10 years ago.
the more succint version which begins with a revert back to the 0.88 version

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by walter

first, apply layout changes to existing Ring

Changed 10 years ago by walter

next, add spiral enhancement as new default

comment:1 Changed 10 years ago by walter

  • Keywords r? added

I had not released that the spiral had already been committed on mainline, so the first patch is a bit more complicated than I had anticipated because it undoes the spiral changes rather than just add the layout enhancements to the basic ring.

Both patches have been tested, applied sequentially.

comment:2 follow-up: Changed 10 years ago by garycmartin

  • Cc tomeu added

Ping, wondering if these were reviewed made it in to 0.90?

comment:3 in reply to: ↑ 2 Changed 10 years ago by tomeu

Replying to garycmartin:

Ping, wondering if these were reviewed made it in to 0.90?

Sorry, I was expecting people would be sending patches to the mailing list. Now it is too late for 0.90.0 but I guess it can go in a subsequent bugfix release.

It would be great if submitters could ping before it's too late.

comment:4 Changed 10 years ago by walter

Sorry about that. I shouldn't impact the user experience, but the maintainers will be happier with this version of the code, I suspect. Whenever it lands, it lands.

Changed 10 years ago by walter

the more succint version which begins with a revert back to the 0.88 version

comment:5 Changed 10 years ago by mtd

  • Cc mtd added

Has this code landed? Does it still need review?

comment:6 Changed 10 years ago by walter

landed? not that I am aware.
reviewed? not that I am aware.

comment:7 Changed 7 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

This code (or something similar has landed.)

comment:8 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.