Opened 11 years ago

Closed 7 years ago

#2079 closed defect (obsolete)

Shell opens svg icons over and over during runtime

Reported by: bernie Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

How to detect:

  1. strace -e open -p <pid_of_shell>
  2. do something, such as opening the frame, running some activities...
  3. observe svg files being opened

The icons in the frame, such as the battery and zoom levels, seem to be reloaded quite often.

Do we have a bug in the icon cache logic?

Change History (5)

comment:1 in reply to: ↑ description ; follow-up: Changed 11 years ago by tomeu

Replying to bernie:

How to detect:

  1. strace -e open -p <pid_of_shell>
  2. do something, such as opening the frame, running some activities...
  3. observe svg files being opened

The icons in the frame, such as the battery and zoom levels, seem to be reloaded quite often.

Do we have a bug in the icon cache logic?

I kind of remember that the disk cache was removed from the shell because the kernel has already an I/O cache and we were duplicating it. The rationale with test results should be somewhere in dev.laptop.org and/or the mailing list.

Often-used icons should be in the surface cache so we shouldn't hit the disk unless this cache has been overflown.

comment:2 in reply to: ↑ 1 Changed 11 years ago by bernie

Replying to tomeu:

I kind of remember that the disk cache was removed from the shell because the kernel has already an I/O cache and we were duplicating it. The rationale with test results should be somewhere in dev.laptop.org and/or the mailing list.

I would agree that caching the plain text is useless.

Often-used icons should be in the surface cache so we shouldn't hit the disk unless this cache has been overflown.

This is what does not seem to be working: the sugar-session process seems to be reloading icons that should stay cached. If the frame icons are purged from the cache, there's a considerable delay every time the frame is being shown.

comment:3 Changed 8 years ago by godiard

  • Milestone changed from Unspecified to 1.0

I reproduced this issue in sugar 0.98.

It's strange, activities icons are not reloaded, but all the icons in the frame.

comment:4 Changed 8 years ago by dnarvaez

  • Milestone changed from 1.0 to Unspecified

comment:5 Changed 7 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

Cannot reproduce in master.

Note: See TracTickets for help on using tickets.