Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#207 closed defect (fixed)

Logout for Sugar

Reported by: sayamindu Owned by: marcopg
Priority: High Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords: r+
Cc: tomeu, erikos, eben, garycmartin Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Continuing from http://dev.laptop.org/ticket/8141
The attached patch tries to check for GDM, and shows the log out option only if the user has logged in via GDM (so it won't be shown in an XO or in sugar-jhbuild)

We also need a better icon for this.

Attachments (5)

sugar-xomenu.patch (1.1 KB) - added by alsroot 12 years ago.
what about reverting if - check if we are on non-XO machine ?
sl_207.patch (1.6 KB) - added by sayamindu 12 years ago.
Updated patch, with support for KDM
system-log-out.svg (1.5 KB) - added by eben 12 years ago.
conditional_logout.patch (1.6 KB) - added by sayamindu 12 years ago.
GConf support
conditional_logout2.patch (1.7 KB) - added by sayamindu 12 years ago.
Strings commented out.

Download all attachments as: .zip

Change History (18)

Changed 12 years ago by alsroot

what about reverting if - check if we are on non-XO machine ?

comment:1 Changed 12 years ago by sayamindu

  • Keywords r? added

comment:2 follow-up: Changed 12 years ago by sayamindu

Checking for XO only hardware is an option as well - but what if someone decides to use it, in say a classmate, but in the same form as in the XO ?

comment:3 in reply to: ↑ 2 Changed 12 years ago by alsroot

Replying to sayamindu:

Checking for XO only hardware is an option as well - but what if someone decides to use it, in say a classmate, but in the same form as in the XO ?

where is a difference between classmate and XO is case of having 'Logout' button :)

comment:4 Changed 12 years ago by alsroot

another situation: login from kdm/xdm/etc

comment:5 Changed 12 years ago by sayamindu

The problem that I see is, if someone decides not to use GDM in the classmate, and say, wants the user to directly log in (just like what happens in a XO), in that case, the log-out button becomes unnecessary.
The point that I want to make is that the logout button should appear in all cases where you have a login manager running (and I agree with you that it needs to check for KDM/XDM as well).

Changed 12 years ago by sayamindu

Updated patch, with support for KDM

Changed 12 years ago by eben

comment:6 Changed 12 years ago by erikos

  • Keywords r+ added; r? removed
<marcopg> unmadindu: not sure "running under a dm" is a good logic
<marcopg> unmadindu: soas runs under a dm and it's single user
<unmadindu> marcopg: hmm - any other ideas ?
<marcopg> I don't know if we can make it automatic
<marcopg> maybe we should enable by default and have single user distro patch some kind of config
<marcopg> not sure
<unmadindu> marcopg: but do you have to log in in soas ?
<marcopg> unmadindu: no it does auto-login
<unmadindu> ok..
<unmadindu> dunno if we can detect auto-login - but it is becoming too complicated :(
<marcopg> autodetecting seems pretty much impossible to me

we added the logout option now, and systems where we have a direct login must patch it out for now.

comment:7 Changed 12 years ago by garycmartin

  • Cc garycmartin added

Testing on XO-1 hardware with joyride 2631, the Logout option is showing in the XO home palette; not sure if this is intentional. The item does seem to correctly logout and back into the Sugar UI (as if you hit atl-ctrl-erase).

comment:8 Changed 12 years ago by marcopg

I'd suggest to make this a gconf preference, so that it can be easily tweaked by distributors. For Fedora spins, for example, we can set the preference from the kickstart.

comment:9 follow-up: Changed 12 years ago by sayamindu

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Keywords r? added; r+ removed
  • Severity set to Blocker

Attached is a patch to do this via GConf. There are two issues involved here:

a) Do we listen for changes to this key ? (we do not expose this setting in the UI anywhere, and no one would probably change it on their own, except for distro makers)

b) We are breaking string freeze. Since this is not a typical user visible string, I suggest that we leave both as blank and add them during the next release cycle.

Changed 12 years ago by sayamindu

GConf support

comment:10 Changed 12 years ago by marcopg

  • Priority changed from normal to High
  • Severity changed from Blocker to Major

comment:11 in reply to: ↑ 9 Changed 12 years ago by tomeu

  • Keywords r+ added; r? removed

Replying to sayamindu:

Attached is a patch to do this via GConf. There are two issues involved here:

a) Do we listen for changes to this key ? (we do not expose this setting in the UI anywhere, and no one would probably change it on their own, except for distro makers)

Don't think it's needed.

b) We are breaking string freeze. Since this is not a typical user visible string, I suggest that we leave both as blank and add them during the next release cycle.

Yup, agreed.

r+

Changed 12 years ago by sayamindu

Strings commented out.

comment:12 Changed 12 years ago by tomeu

  • Resolution set to fixed
  • Status changed from new to closed

comment:13 Changed 8 years ago by godiard

  • Milestone 0.84 deleted

Milestone 0.84 deleted

Note: See TracTickets for help on using tickets.