Opened 11 years ago

Closed 11 years ago

#2065 closed defect (invalid)

Upgrading bundles does not cleanup old files

Reported by: bernie Owned by: tch
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: sugar-love
Cc: m_anish Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

On bundle upgrades, the old files in ~/Activities don't get erased!

Besides the waste of disk space, this may potentially result in real bugs.

Change History (5)

comment:1 Changed 11 years ago by bernie

  • Cc m_anish added

comment:2 Changed 11 years ago by bernie

  • Keywords sugar-love added

comment:3 Changed 11 years ago by bernie

  • Owner changed from tomeu to tch
  • Status changed from new to assigned

comment:4 Changed 11 years ago by tch

Looking at jarabe,model.bundleregistry #407 upgrade method. The code logic seems to be deleting the old files.

The only scenario where i could find where the old files are not deleted, was when trying to delete system activities.

In fact, I tried this, on my jhbuild devel environent:

  1. mv $SUGAR_JHBUILD_PATH/install/share/sugar/activities/Terminal.activity ~/Activities
  2. vim ~/Activities/Terminal.activity/iwashere.probes
  3. make sure the file is really there
  4. Started sugar on jhbuild and upgraded
  5. Checked again for iwashere.probes.. and it was gone...

So, it actually deletes the older files, except when they are systems activities.

comment:5 Changed 11 years ago by bernie

  • Resolution set to invalid
  • Status changed from assigned to closed

Ok, this bug is invalid then.

Note: See TracTickets for help on using tickets.