Opened 10 years ago

Closed 9 years ago

#1900 closed defect (fixed)

Read doesn't work with gnome-python-evince-2.30.0

Reported by: alsroot Owned by: lucian
Priority: Immediate Milestone: Unspecified
Component: Read Version: 0.88.x
Severity: Blocker Keywords:
Cc: pbrobinson, mchua, sdz, sascha_silbe, tomeu, sayamindu Distribution/OS:
Bug Status: Assigned

Description

Having:
gnome-python-evince-2.30.0-1mdv2010.1
libevince2-2.30.0-1mdv2010.1
evince-2.30.0-1mdv2010.1

Read-78 (looks like older versions as well since they use the same API) doesn't work. It can't find at least:

  • evince.View.set_screen_dpi
  • evince.factory_get_document (should be evince.document_factory_get_document)
  • evince.View.props.zoom

I'm setting Severity to Critical since Read-78(and looks like older versions) can't work in recent distributions.

Attachments (1)

0001-Switch-to-new-API-for-getting-pdf-title-1900.patch (1.5 KB) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 10 years ago by sdz

  • Bug Status changed from Unconfirmed to Assigned
  • Cc pbrobinson mchua added
  • Priority changed from Unspecified by Maintainer to Immediate
  • Severity changed from Critical to Blocker

This simply prevents Read from working on Fedora 13 - and hence in SoaS - and will presumably cause it to be removed, since it got noticed past final freeze.

comment:2 Changed 10 years ago by sdz

  • Cc sdz added

comment:3 follow-up: Changed 10 years ago by sayamindu

Ouch - it looks like a huge portion of the Evince API has changed (a quick look seem to suggest that the entire document loading model is different).
I'm not sure how easy it would be port to the new API, but it looks like it will take some time.

comment:4 Changed 10 years ago by sascha_silbe

  • Cc sascha_silbe added
  • Distribution/OS Mandriva deleted

comment:5 in reply to: ↑ 3 Changed 10 years ago by tomeu

  • Cc tomeu added

Replying to sayamindu:

Ouch - it looks like a huge portion of the Evince API has changed (a quick look seem to suggest that the entire document loading model is different).
I'm not sure how easy it would be port to the new API, but it looks like it will take some time.

This suggests that the python bindings have been updated already to the new API:

http://mail.gnome.org/archives/release-team/2010-June/msg00029.html

comment:6 Changed 10 years ago by lucian

Yeah, the evince python binding in f12 and f13 follows http://library.gnome.org/devel/libevview/2.30/

The changes aren't major, just a few renamed methods and a separation between Documents and Models.

comment:7 Changed 10 years ago by lucian

After trying my hand at porting Read, I found out that the following are truly gone:

  • evince.View.set_screen_dpi
  • evince.View.props.zoom

I've reported this as a bug https://bugzilla.gnome.org/show_bug.cgi?id=624780

comment:8 Changed 10 years ago by lucian

  • Owner changed from sayamindu to lucian
  • Status changed from new to accepted

I ported Read to libevview 2.80. The only lost feature is set_screen_dpi, but it's possible that libevview 2.80 can do that itself.

Note that I've made two merge requests, the first one has the wrong branch.

comment:9 Changed 10 years ago by lucian

My mistake, I meant 2.30, not 2.80.

comment:10 Changed 10 years ago by lfaraone

  • Keywords r? added

comment:11 Changed 10 years ago by alsroot

  • Cc sayamindu added

comment:12 Changed 10 years ago by pbrobinson

There's further issues with gnome-python2-evince 2.31.x due to the following changes in the evince api linked. This will affect both SoaS v4 based on Fedora 14 and the new OLPC F-14 builds so a fix would be appreciated.

http://git.gnome.org/browse/evince/diff/libdocument/ev-selection.h?id=18d2af9bce80392407fae997c8dfa029f5a54123

Traceback (most recent call last):

File "/usr/bin/sugar-activity", line 21, in <module>

main.main()

File "/usr/lib/python2.7/site-packages/sugar/activity/main.py", line 115, in main

module = import(module_name)

File "/home/bernie/Activities/Read.activity/readactivity.py", line 25, in <module>

import evince

ImportError: /usr/lib64/python2.7/site-packages/gtk-2.0/evince.so: undefined symbol: ev_selection_get_selection_map
Exited with status 1, pid 5410 data (None, <open file '<fdopen>', mode 'w' at 0x261a150>, 'c9a33f84910d7499496f16cb75f4a930a1f234d4')

comment:13 follow-up: Changed 10 years ago by alsroot

0001-Switch-to-new-API-for-getting-pdf-title-1900.patch

Small fix to run Read-79 on ubuntu-10.04 (evince-2.30.0).

comment:14 in reply to: ↑ 13 Changed 10 years ago by lucian

Replying to alsroot:

0001-Switch-to-new-API-for-getting-pdf-title-1900.patch

Small fix to run Read-79 on ubuntu-10.04 (evince-2.30.0).

Applied, but not tested, as I have no dev environment right now.

http://git.sugarlabs.org/projects/read/repos/evince-2-30/commits/cd64b91c75f2fa0ed4626aa7bb257b25ed2675d1

comment:15 Changed 10 years ago by godiard

I have fixed the the bindings in F14 and sent upstream.

OLPC ticket http://dev.laptop.org/ticket/10618

Gnome ticket https://bugzilla.gnome.org/show_bug.cgi?id=639758

We need the bindings packaged now, anybody who can help?

comment:16 Changed 10 years ago by sascha_silbe

  • Keywords r? removed

Lucians fix has been landed as 5832d4d, additional EPUB fixes have been committed as 5aa9840. Is there anything left to do or can we close this ticket?

comment:17 Changed 9 years ago by godiard

  • Resolution set to fixed
  • Status changed from accepted to closed

The bindings are package in Fedora and Read 89 was published.

Note: See TracTickets for help on using tickets.