Opened 11 years ago

Closed 10 years ago

#1771 closed defect (fixed)

paint overwrites file type instead of creating new file

Reported by: walter Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Paint Version: Git as of bugdate
Severity: Critical Keywords:
Cc: erikos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Paint will open an SVG file and write it out as PNG. This is appropriate behavior except it should create a new datastore/Journal object rather than overwriting the original SVG file.

Change History (4)

comment:1 Changed 11 years ago by walter

  • Cc erikos added

See 1772 re getting SVG files to open on Browse. Until this bug is fixed and if that patch is applied, it would be better to have Browse be the default activity for opening SVG files since it would do so without modifying them irreversibly. (Note that this bug is marked Critical because data is lost).

This would involve adding the line:

image/svg+xml org.laptop.WebActivity

to mime.defaults in /usr/share/sugar/data (sugar/data/mime.defaults)

comment:2 Changed 10 years ago by godiard

  • Owner changed from manu to godiard
  • Status changed from new to assigned

commited to git

comment:3 Changed 10 years ago by godiard

|TestCase| Download a svg image with Browse. Then open it with Paint, draw anything over it and close Paint. In the Journal you must have two images the original svg and the modified png.

comment:4 Changed 10 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.