Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#177 closed defect (fixed)

palettes are created several times

Reported by: tomeu Owned by: marcopg
Priority: Urgent Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Blocker Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Seems like the invoker is calling create_palette() every time it needs a palette, but the palette is still referenced by the widget, thus accumulating.

To check, print self.props.palette at the start of create_palette().

Change History (3)

comment:1 Changed 12 years ago by marcopg

  • Bug Status set to New
  • Distribution/OS set to Unspecified
  • Milestone set to 0.84
  • Priority changed from normal to Urgent
  • Severity set to Blocker

comment:2 Changed 12 years ago by marcopg

  • Resolution set to fixed
  • Status changed from new to closed

I think I fixed this a while ago and Tomeu cannot reproduce.

comment:3 Changed 8 years ago by godiard

  • Milestone 0.84 deleted

Milestone 0.84 deleted

Note: See TracTickets for help on using tickets.