Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#1709 closed enhancement (fixed)

Colors used for block highlighting (current running block vs. error-reporting)

Reported by: rgs Owned by: walter
Priority: Normal Milestone:
Component: Turtleart Version: Git as of bugdate
Severity: Unspecified Keywords: error handling highlighting block
Cc: rgs Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

To enhance visual feedback; it would be nice to have a different color for block highlighting depending on the case.

Known cases where highlighting is used:

1) to show running block

2) when a syntax (or runtime) error is found, to show at which block the error was encountered (and the code path is shown by highlighting the calling blocks in the upper levels of the stack as well).

Observations:

<walterbender> rgs_: well... right now I precompute the highlight sprites... I suppose I could precompute a 3rd layer... but I worry about performance...

One approach could be, in order to keep performance problems away, to precompute the highlighted blocks used to show the running block and to compute on the fly for the error-reporting case. This makes sense because performance is less important when doing error-reporting (then when running code).

On the other hand, in the future we might want to expose a way to turn on/off highlighting (for the running and error-reporting case). But we should at least have 3 or 4 months of feedback from the field before taking the path of overloading the UI.

Another consideration is what color to use for each case where highlighting is used. One option would be to infer the colors from your Sugar avatar. Another would be to have something static (i.e.: blue for the running block and red for the stacktrace when doing error-reporting).

Change History (7)

comment:1 Changed 9 years ago by rgs

  • Summary changed from Different color for block highlighting (running block vs. error highligting) to Colors used for block highlighting (current running block vs. error-reporting)

comment:2 follow-up: Changed 9 years ago by walter

Not sure where to go with this. Right now, when you get an error, the block associated with the error remains highlighted. Is there really an advantage to changing the color?

comment:3 Changed 9 years ago by walter

  • Milestone changed from Unspecified by Release Team to 0.90

comment:4 in reply to: ↑ 2 Changed 9 years ago by rgs

Replying to walter:

Is there really an advantage to changing the color?

Maybe not. Feedback from the field will tell us if this would be useful.

comment:5 Changed 9 years ago by walter

  • Priority changed from Immediate to Normal

comment:6 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

V105 has a new highlight scheme that makes it much more clear where you are in the program.

comment:7 Changed 6 years ago by dnarvaez

  • Cc changed from rgs, to rgs
  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.