Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#1662 closed defect (fixed)

file additions break non-clean build

Reported by: garycmartin Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords: r+
Cc: bernie Distribution/OS: Unspecified
Bug Status: New

Description

Just updated and built the latest sugar-jhbuild (on a Fedora 11 VM) but it now fails to start Sugar due to an ImportError for olpcmesh:

[garycmartin@localhost sugar-jhbuild]$ ./sugar-jhbuild run sugar-emulator --fullscreen --scaling 100 --dpi 133
SELinux: Disabled on system, not enabling in X server
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)

** (sugar-session:1060): WARNING **: Trying to register gtype 'WnckWindowState' as flags when in fact it is of type 'GEnum'

** (sugar-session:1060): WARNING **: Trying to register gtype 'WnckWindowActions' as flags when in fact it is of type 'GEnum'

** (sugar-session:1060): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as flags when in fact it is of type 'GEnum'

** (sugar-session:1060): WARNING **: Trying to register gtype 'XklEngineFeatures' as flags when in fact it is of type 'GEnum'
Traceback (most recent call last):
  File "/home/garycmartin/sugar-jhbuild/install/bin/sugar-session", line 55, in <module>
    from jarabe.desktop import homewindow
  File "/home/garycmartin/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/desktop/homewindow.py", line 24, in <module>
    from jarabe.desktop.meshbox import MeshBox
  File "/home/garycmartin/sugar-jhbuild/install/lib/python2.6/site-packages/jarabe/desktop/meshbox.py", line 56, in <module>
    from jarabe.model.olpcmesh import OlpcMeshManager
ImportError: No module named olpcmesh
Window manager warning: Fatal IO error 11 (Resource temporarily unavailable) on display ':30'.

Attachments (4)

sugar-artwork-maintainer-mode.patch (862 bytes) - added by bernie 9 years ago.
sugar-base-maintainer-mode.patch (891 bytes) - added by bernie 9 years ago.
sugar-toolkit-maintainer-mode.patch (891 bytes) - added by bernie 9 years ago.
sugar-maintainer-mode.patch (567 bytes) - added by bernie 9 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 follow-up: Changed 9 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Severity changed from Critical to Major

As a "workaround" you can rebuild sugar:

cd sugar-jhbuild/source/sugar
make distclean
cd ../..
./sugar-jhbuild buildone -n sugar

A proper fix would be to ensure that build system changes (adding a new module) cause auto* to be re-run.

comment:2 Changed 9 years ago by garycmartin

Many thanks, that got me up and running again.

comment:3 in reply to: ↑ 1 ; follow-up: Changed 9 years ago by tomeu

  • Cc bernie added

Replying to sascha_silbe:

As a "workaround" you can rebuild sugar:

cd sugar-jhbuild/source/sugar
make distclean
cd ../..
./sugar-jhbuild buildone -n sugar

A proper fix would be to ensure that build system changes (adding a new module) cause auto* to be re-run.

AFAIU, that's what --enable-maintainer-mode is for, I don't know why Bernie didn't pushed his patches for this. We should ping him.

Can this particular ticket be closed? This happens any time someone adds a new file.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 9 years ago by sascha_silbe

  • Summary changed from sugar-jhbuild fails to start due to missing olpcmesh ImportError to file additions break non-clean build

Replying to tomeu:

A proper fix would be to ensure that build system changes (adding a new module) cause auto* to be re-run.

AFAIU, that's what --enable-maintainer-mode is for, I don't know why Bernie didn't pushed his patches for this. We should ping him.

I remembered something about this as well, but wasn't sure what change exactly it was. Where was this --enable-maintainer-mode to be added, in sugar-jhbuild or in autogen.sh of each package?

Can this particular ticket be closed? This happens any time someone adds a new file.

As long as it can happen it's a bug, so let's keep it open. I'm adjusting the subject.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 9 years ago by tomeu

Replying to sascha_silbe:

Replying to tomeu:

A proper fix would be to ensure that build system changes (adding a new module) cause auto* to be re-run.

AFAIU, that's what --enable-maintainer-mode is for, I don't know why Bernie didn't pushed his patches for this. We should ping him.

I remembered something about this as well, but wasn't sure what change exactly it was. Where was this --enable-maintainer-mode to be added, in sugar-jhbuild or in autogen.sh of each package?

I think we have to add a line to each configure.ac, and have sugar-jhbuild pass the configure switch for each module.

comment:6 in reply to: ↑ 5 Changed 9 years ago by bernie

I think we have to add a line to each configure.ac, and have sugar-jhbuild pass the configure switch for each module.

I did exactly this, no long ago. But then I was too lazy to open a bug in trac and attach the patches (and I totally hate trac :-).

Anyway, here they are now. Any other modules I might have missed need a similar massage.

Changed 9 years ago by bernie

Changed 9 years ago by bernie

Changed 9 years ago by bernie

Changed 9 years ago by bernie

comment:7 Changed 9 years ago by bernie

  • Keywords r? added

If maintainers like the above patches, I'll commit them.

comment:8 Changed 9 years ago by tomeu

  • Keywords r+ added; r? removed

Thanks, please push

comment:9 Changed 9 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the patches Bernie - all pushed.

comment:10 Changed 6 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.