Opened 13 years ago

Closed 9 years ago

#1428 closed defect (invalid)

labels should be used with new toolbar design to prevent black items on small screens

Reported by: walter Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

If you have a small screen such that toolbar items run off the end, then the toolbar items appear as entries in a list... so far so good. But if you neglected to assign a label= entry when creating the toolbar, then the entry in the list is blank.

"label= " properly assigns the label, which fixes the problem, but I suspect that many activity developers are not using it since the label never appears except in this corner case.

help_toolbar_button = ToolbarButton(

label=_("Help"),
page=help_toolbar,
icon_name='help-toolbar')

See attached figures.

Attachments (2)

blank-entry.png (59.1 KB) - added by walter 13 years ago.
without label=
missing-label-workaround.png (61.7 KB) - added by walter 13 years ago.
with label=_('Help')

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by walter

without label=

Changed 13 years ago by walter

with label=_('Help')

comment:1 Changed 9 years ago by dnarvaez

  • Resolution set to invalid
  • Status changed from new to closed

It sounds like a problem with activities, not sure keeping the bug here helps anything, should file bugs for each activity affected.

Note: See TracTickets for help on using tickets.