Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#133 closed defect (notsugar)

Refactor the About my XO setting to be more generic

Reported by: mungewell Owned by: morgs
Priority: major Milestone:
Component: Sugar Version:
Severity: Blocker Keywords:
Cc: Eben Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

In Jhbuild 20081217 Settings

It is understandable that serial number, build, firmware and wireless firmware might be unavailable on a normal PC running Sugar.

But surely the license should be available.....

Change History (5)

comment:1 Changed 12 years ago by erikos

  • Owner changed from marcopg to morgs
  • Priority changed from minor to major
  • Status changed from new to assigned
  • Summary changed from Settings - License is not available. to Refactor the About my XO setting to be more generic

Morgan took the item: "Better separation of XO features in the control panel so they can be removed for distros" listed in our TODO: http://sugarlabs.org/go/DevelopmentTeam/TODO

comment:2 Changed 12 years ago by erikos

  • Cc Eben added

Eben can you comment on the design: Name the section 'About my Computer' and display only licence field and the Sugar version number for non XO ?

comment:3 Changed 12 years ago by tomeu

  • Milestone set to 0.86

Ok, have hidden the fields identity, firmware and wireless firmware on non-xo machines.

Also will display the distro version in the build field.

Moving this ticket to 0.86 where we can do better accommodating the different OSes where Sugar runs on.

Fixed in http://git.sugarlabs.org/projects/sugar/repos/mainline/commits/83b358a5

comment:4 Changed 12 years ago by alsroot

  • Bug Status set to Unconfirmed
  • Distribution/OS set to Unspecified
  • Resolution set to notsugar
  • Severity set to Blocker
  • Status changed from assigned to closed

I'm closing this ticket with "notsugar" status, since stuff like serial number, build, firmware are deployment specific.

Another way, we can provide special API for this info in sugar, if so please create feature page http://wiki.sugarlabs.org/go/Features/Feature_Template

comment:5 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.