Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#1301 closed defect (fixed)

Paltte isn't being closed after activating some kinds of subwidgets

Reported by: alsroot Owned by: alsroot
Priority: High Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

This issue could be reproduced with menus:

  • open palette with menu(palette for Journal entries)
  • open submenu("Resume with")
  • move cursor to newly opened submenu
  • move cursor away from menu/palette
  • palette wasn't closed

or with comboboxes.

    def __enter_notify_event_cb(self, widget, event):
        if event.detail != gtk.gdk.NOTIFY_INFERIOR and \
                event.mode == gtk.gdk.CROSSING_NORMAL:
            self.on_enter(event)

    def __leave_notify_event_cb(self, widget, event):
        if event.detail != gtk.gdk.NOTIFY_INFERIOR and \
                event.mode == gtk.gdk.CROSSING_NORMAL:
            self.on_leave(event)

This code doesn't invoke on_enter/on_leave correctly for previously mentioned situations.

Attachments (1)

sugar-1301.patch (951 bytes) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by alsroot

  • Keywords r? added
  • Milestone changed from Unspecified by Release Team to 0.86
  • Summary changed from Paltte isn't being closed if after activating subwidgets to Paltte isn't being closed after activating some kinds of subwidgets
  • Version changed from Unspecified to Git as of bugdate

In my mind correct fix could be too invasive for 0.86,
but this issue have odd consequence:
|TestCase|

  • open journal entry palette
  • open "Resume with" submenu
  • not closing palette and submenu, fast right click on another Journal entry
  • palette should be closed but submenu still exists

So, minimal fix could be just hiding submenu(but it still doesn't have predictable behaviour since enter_notify_event_cb() doesn't invoke on_enter()) but it could be enough for 0.86(we have similar situation with comboboxes).

Changed 10 years ago by alsroot

comment:2 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Owner changed from erikos to alsroot
  • Status changed from new to assigned

comment:5 Changed 10 years ago by alsroot

previous sugar-0.86 patches just suppressed #comment:1's testcase

comment:6 Changed 9 years ago by tomeu

  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major

I'm a bit confused, what remains to be done?

comment:7 Changed 9 years ago by alsroot

  • Milestone changed from 0.88 to 0.90

bug still exists, pushed commit just fixed comment:1's test case

comment:8 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:9 Changed 6 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:10 Changed 6 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.