Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#1292 closed defect (fixed)

Do not fail on immediate second palette openning for bottom icons

Reported by: alsroot Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: r?
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

|TestCase|

  • apply #1285 patch
  • open any button with second palette at bottom of the screen by right clicking(w/o waiting for second palette timeout)

Attachments (2)

sugar-1292.patch (843 bytes) - added by alsroot 10 years ago.
Untitled.png (6.6 KB) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by alsroot

comment:1 Changed 10 years ago by alsroot

  • Keywords r? added

Changed 10 years ago by alsroot

comment:2 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

the problem is that in draw_rectangle() palette ins not allocated and we can't get proper sizes from get_allocation()

http://git.sugarlabs.org/projects/sugar-toolkit/repos/mainline/commits/cb5951d3b995b23217fc7d9771c6bf0c4f53adba

comment:3 Changed 6 years ago by dnarvaez

  • Component changed from sugar-toolkit to Sugar

comment:4 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.