Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#1262 closed enhancement (wontfix)

Process non-ds object in the right way in Journal

Reported by: alsroot Owned by: tomeu
Priority: Normal Milestone:
Component: Sugar Version: 0.85.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

For 0.86 edit widgets could be just insensitive

Attachments (1)

sugar-1262.patch (5.6 KB) - added by alsroot 11 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by alsroot

  • Keywords r? added

comment:2 Changed 11 years ago by alsroot

  • Milestone changed from Unspecified by Release Team to 0.86

comment:3 follow-up: Changed 11 years ago by tomeu

  • Keywords r! added; r? removed

The patch looks good, just a couple of questions:

374	 	def find(query, page_size): 
 	374	def find(query_, page_size): 

Why do we need to make this change?

        mountpoints = metadata.get('mountpoints')

When do we have a 'mountpoints' property? Didn't knew about it.

comment:4 in reply to: ↑ 3 Changed 11 years ago by alsroot

Replying to tomeu:

The patch looks good, just a couple of questions:

374	 	def find(query, page_size): 
 	374	def find(query_, page_size): 

because it changes query argument(by poping 'mountpoints'), so next invoking of ListModel() in listview.py:287 will not contain 'mountpoints'

Why do we need to make this change?

        mountpoints = metadata.get('mountpoints')

When do we have a 'mountpoints' property? Didn't knew about it.

model.is_editable() is used for query as well(when we don't have any row, see the patch)

Changed 11 years ago by alsroot

comment:5 Changed 11 years ago by alsroot

  • Keywords r? added; r! removed

comment:6 Changed 11 years ago by tomeu

  • Keywords r+ added; r? removed

Looks good to me, though I would do:

is_editable = self._query.get('mountpoints', '') == '/'
self.cell_title.props.editable = is_editable

instead of

315             is_editable = False 
316	        mountpoints = self._query.get('mountpoints') 
317	        if mountpoints is not None and len(mountpoints): 
318	            is_editable = mountpoints[0] == '/' 
319	        self.cell_title.props.editable = is_editable 

comment:8 Changed 11 years ago by alsroot

Related non-ds issues: #1411, #1415

comment:9 Changed 11 years ago by alsroot

  • Keywords r+ removed
  • Milestone changed from 0.86 to 0.88
  • Priority changed from Unspecified by Maintainer to Normal
  • Type changed from defect to enhancement
  • Version changed from Git as of bugdate to 0.85.x

Reopen ticket to have more essential behaviour in 0.88

comment:10 Changed 11 years ago by alsroot

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:11 Changed 11 years ago by garycmartin

  • Bug Status changed from Unconfirmed to Needinfo

Did this make it in to 0.88? Perhaps push back additional work (if they are not bug fixes) to 0.90?

comment:12 Changed 11 years ago by alsroot

  • Resolution set to wontfix
  • Status changed from reopened to closed

I guess it could be closed since there is #1636 which implements RW for non-ds objects.

comment:13 Changed 7 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.