Opened 12 years ago

Closed 7 years ago

#1231 closed defect (obsolete)

Traceback if volume cannot be mounted

Reported by: sascha_silbe Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by sascha_silbe)

Traceback (most recent call last):
  File "/home/sascha.silbe/sugar-jhbuild/install/share/sugar/extensions/deviceicon/volume.py", line 101, in _mount_cb
    volume.mount_finish(result)
gio.Error: You are not supposed to show G_IO_ERROR_FAILED_HANDLED in the UI

No device icon appeared in the Journal.

Change History (7)

comment:1 Changed 12 years ago by sascha_silbe

  • Description modified (diff)

comment:2 Changed 12 years ago by sascha_silbe

Additional info about the SD card that might help in reproducing the issue:

sascha.silbe@caravan:~$ sudo /sbin/fdisk -l /dev/sdc

Disk /dev/sdc: 1973 MB, 1973420032 bytes
60 heads, 59 sectors/track, 1088 cylinders
Units = cylinders of 3540 * 512 = 1812480 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1        1089     1927100+   6  FAT16
sascha.silbe@caravan:~$ sudo file -s /dev/sdc1 
/dev/sdc1: x86 boot sector, code offset 0x0, OEM-ID "        ", sectors/cluster 64, root entries 512, Media descriptor 0xf8, sectors/FAT 236, heads 64, hidden sectors 135, sectors 3854201 (volumes > 32 MB) , serial number 0x12ec449e, label: "           ", FAT (16 bit)
sascha.silbe@caravan:~$ 

comment:3 Changed 12 years ago by tomeu

Anything in dmesg after the failure?

comment:4 Changed 11 years ago by sascha_silbe

  • Summary changed from Traceback when plugging in SD card reader (with card) to Traceback if volume cannot be mounted

Encountered this today on an eMac (no external storage attached):

1258057706.889875 DEBUG root: _mount_cb <__main__.GProxyVolume at 0x111b2508: Hallo> <gio.SimpleAsyncResult object at 0x111b2530 (GSimpleAsyncResult at 0x111f25a8)>
Traceback (most recent call last):
  File "/usr/share/sugar/extensions/deviceicon/volume.py", line 107, in _mount_cb
    volume.mount_finish(result)
gio.Error: You are not supposed to show G_IO_ERROR_FAILED_HANDLED in the UI
1258057706.987935 DEBUG root: _mount_cb <__main__.GProxyVolume at 0x111b25d0: 134.2 MB Media> <gio.SimpleAsyncResult object at 0x111b25f8 (GSimpleAsyncResult at 0x1124c810)>
Traceback (most recent call last):
  File "/usr/share/sugar/extensions/deviceicon/volume.py", line 107, in _mount_cb
    volume.mount_finish(result)
gio.Error: You are not supposed to show G_IO_ERROR_FAILED_HANDLED in the UI
1258057708.494256 DEBUG sugar.presence.presenceservice: Reused proxy <Buddy object at 0x10efc7d8 (sugar+presence+buddy+Buddy at 0x10aef220)>

Nothing in dmesg or syslog. IIRC "Hallo" is the name of the native Mac partition (not mounted inside Linux).

comment:5 Changed 8 years ago by dnarvaez

  • Milestone changed from 0.86 to Unspecified

comment:6 Changed 8 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:7 Changed 7 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

Cannot reproduce, very old bug.

Note: See TracTickets for help on using tickets.