Opened 11 years ago

Closed 8 years ago

Last modified 7 years ago

#1152 closed enhancement (incomplete)

automate school server registration

Reported by: dsd Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: rgs, bernie, tch Distribution/OS: Unspecified
Bug Status: Needinfo

Description

Getting first time users to register is quite a challenge and this can be automated.

Here are some hacks for sugar-0.82 to implement this, dependent on #1151. It is tricky because python doesn't offer asynchronous xmlrpc, and threading should also be avoided, so the approach I took is to run the registration as a subprocess which communicates back to sugar and the presence service using dbus.

It runs on first sugar boot, on sugar boot when a network connection is already established, and every time that a network connection is established after boot. It is unconditional meaning that it will register to any server, including ones that it was already registered to, or ones that it has never seen before. this means that there are no issues when an XS gets reinstalled, or when the kid moves school, but it also means that someone could set up something to receive a copy of a kids files (because of the automatic backup system).

Attachments (2)

autoreg.patch (3.1 KB) - added by dsd 11 years ago.
xs-register (2.4 KB) - added by dsd 11 years ago.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by dsd

Changed 11 years ago by dsd

comment:1 Changed 11 years ago by tomeu

  • Bug Status changed from Unconfirmed to Needinfo
  • Milestone changed from Unspecified by Release Team to 0.86

Is this only submitted for 0.82?

About using an external process, why not using async gio calls to the http server? I guess the xml stuff that xmlrpc encapsulates isn't worth the extra process and dbus.

See http://wiki.sugarlabs.org/go/Development_Team/CodeReview if you want to submit this code for review.

comment:2 Changed 11 years ago by dsd

yes, only for 0.82. I don't have time to do it for other versions.

python's xmlrpc interface is sync-only. if you can find a way of making it asynchronous in-process without causing too much mess, please go ahead :)

comment:3 Changed 11 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

Looks like this one won't make 0.88 :(

comment:4 Changed 11 years ago by rgs

  • Cc rgs added

comment:5 Changed 11 years ago by bernie

  • Cc bernie tch added

comment:6 Changed 10 years ago by satellit

related to http://bugs.sugarlabs.org/ticket/2432

Use of "Register" on F3 dropdown menu Hangs running soas-i386-20101008.16.iso CD nothing responds

Note: after about 5 minute of blacked out dropdown, "Registration Failed" cannot connect to server (OK). message appears.

This is too long an interval. Most users will give up on the hung CD rather than waiting

comment:8 Changed 8 years ago by dnarvaez

  • Resolution set to incomplete
  • Status changed from new to closed

comment:9 Changed 7 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.