Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1118 closed defect (fixed)

Terminal window offset on the XO

Reported by: sascha_silbe Owned by: sayamindu
Priority: Unspecified by Maintainer Milestone:
Component: Terminal Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Since the switch to metacity, the Terminal window is offset on my XO (running sugar-jhbuild on DebXO), with part of it being out of screen (=> more or less unusable). It works fine in my VMs, so it may be resolution-dependent.

Attachments (1)

Terminal-XO-offset.png (31.5 KB) - added by sascha_silbe 12 years ago.
full screen shot of Terminal on the XO showing the offset

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by sascha_silbe

full screen shot of Terminal on the XO showing the offset

comment:1 Changed 12 years ago by sayamindu

I could reproduce this with Pippy, and the following patch in sugar-toolkit seems to fix this:

diff --git a/src/sugar/graphics/window.py b/src/sugar/graphics/window.py
index 0d53776..aba2e21 100644
--- a/src/sugar/graphics/window.py
+++ b/src/sugar/graphics/window.py
@@ -182,6 +182,7 @@ class Window(gtk.Window):
         group = gtk.Window()
         group.realize()
         window.window.set_group(group.window)
+        self.set_position(gtk.WIN_POS_CENTER_ALWAYS)
 
     def __window_state_event_cb(self, window, event):
         if not (event.changed_mask & gtk.gdk.WINDOW_STATE_FULLSCREEN):

Could you try and verify ?

comment:2 Changed 12 years ago by walter

I tried this patch and it seemed to fix some other activities that were off center as well, e.g., domino and ecumondo

comment:3 Changed 12 years ago by sascha_silbe

Unfortunately this doesn't fix Terminal for me (not tried any other activity yet). I've been not been able to reproduce it on any other host or even sugar-emulator on the XO, only when running sugar directly on the native X server. Could just be timing related, though.

comment:4 Changed 12 years ago by sascha_silbe

FWIW I have been able to reproduce it by running sugar-jhbuild on a different host (running Debian squeeze) with the X server attached to the XO via SSH forwarding (i.e. X server runs on the XO, sugar-jhbuild on another host), but not the other way round. So the X server on the XO might play a role in this...

For reference, these are the versions of the Xorg packages installed on the XO:

olpc@xo-sascha:~$ dpkg -l '*xorg*'|grep ^i
ii  xserver-xorg                      1:7.3+19                    the X.Org X server
ii  xserver-xorg-core                 2:1.4.2-11                  Xorg X server - core server
ii  xserver-xorg-input-all            1:7.3+19                    the X.Org X server -- input driver metapacka
ii  xserver-xorg-input-evdev          1:2.0.8-1                   X.Org X server -- evdev input driver
ii  xserver-xorg-input-kbd            1:1.3.1-1                   X.Org X server -- keyboard input driver
ii  xserver-xorg-input-mouse          1:1.3.0-1                   X.Org X server -- mouse input driver
ii  xserver-xorg-input-synaptics      0.14.7~git20070706-3        Synaptics TouchPad driver for X.Org/XFree86 
ii  xserver-xorg-input-wacom          0.8.1.6-1                   X.Org X server -- Wacom input driver
ii  xserver-xorg-video-geode          2.11.1-1                    X.Org server -- Geode GX2/LX display driver

comment:5 Changed 12 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 929ce5a3cbf9.

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.