Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#111 closed defect (notsugar)

gconf-dbus error with sugar-jhbuild

Reported by: shenki Owned by: sascha_silbe
Priority: major Milestone:
Component: sugar-jhbuild Version:
Severity: Blocker Keywords:
Cc: sascha_silbe Distribution/OS: Ubuntu
Bug Status: New

Description

  • Ubuntu Intrepid
  • sugar-jhbuild as of 2008-12-12

'sugar-jhbuild run' launches xephyr window to appear with the X background, and Sugar mouse cursor. Doesn't get any further.

A debugging session a month or so ago suggested it was related to a gconf-dbus issue.

Attachments (2)

sugar-jhbuild-run.log (2.7 KB) - added by shenki 12 years ago.
log of sugar-jhbuild run console messages
messages.log (660 bytes) - added by shenki 12 years ago.
Relevant messages from /var/log/messages

Download all attachments as: .zip

Change History (13)

Changed 12 years ago by shenki

log of sugar-jhbuild run console messages

Changed 12 years ago by shenki

Relevant messages from /var/log/messages

comment:1 Changed 12 years ago by dfarning

  • Bug Status set to Unconfimed
  • Distribution/OS set to Unspecified
  • Resolution set to obsolete
  • Status changed from new to closed

Seems to work fine as of 2008-01-26

comment:2 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added
  • Severity set to Blocker

comment:3 Changed 12 years ago by shenki

  • Resolution obsolete deleted
  • Status changed from closed to reopened

http://lists.sugarlabs.org/archive/sugar-devel/2009-February/011473.html appears to be this issue. I also still see it on Ubuntu Jaunty, amd64.

comment:4 Changed 12 years ago by sascha_silbe

  • Bug Status changed from Unconfimed to New
  • Distribution/OS changed from Unspecified to Ubuntu

As diagnosed on the mailing list, the issue is as follows:

  1. sugar-jhbuild is expected to use the system-supplied gconf python wrapper with the gconf library built by sugar-jhbuild.
  2. sugar-jhbuild set LD_LIBRARY_PATH to the directory containing the gconf-library built by sugar-jhbuild.
  3. Ubuntu python-gconf contains an rpath setting, causing the dynamic linker to search /usr/lib before LB_LIBRARY_PATH.
  4. As /usr/lib contains the system-supplied gconf library, it will get used instead of the one built by sugar-jhbuild.
  5. sugar won't work with the system-supplied gconf library.

comment:5 Changed 12 years ago by sascha_silbe

Reported to Ubuntu as Bug #327671.
Might affect Debian as well.

comment:6 Changed 12 years ago by erikos

  • Component changed from sugar to sugar-jhbuild

comment:7 Changed 12 years ago by homunq

A workaround from the wiki:

" Note that Debian Unstable and derived distros (e.g. Ubuntu Intrepid) contain a bug in python-gnome that impedes running jhbuild

To work around this use chrpath to remove the rpath setting from your system's gconf.so:

sudo aptitude install chrpath
find /usr/lib/python-support/python-gnome2/python2.5/gtk-2.0 -name "*.so" | sudo xargs chrpath -d

"

comment:8 Changed 12 years ago by homunq

The following fixed a similar symptom, which is a separate bug.

<silbe> homunq_: check that you have all of these packages installed: libpopt-dev, zip, unzip, python-gnome2, python-gnome2-desktop

comment:9 Changed 12 years ago by sascha_silbe

  • Owner changed from marcopg to sascha_silbe
  • Status changed from reopened to assigned

comment:10 Changed 12 years ago by sascha_silbe

  • Resolution set to notsugar
  • Status changed from assigned to closed

Resolving as "notsugar" since
a) it's an upstream bug, so all we can do about it is file bugs upstream (which we already did, at least for Ubuntu) and
b) there's an easy workaround that's documented prominently on the wiki.

Feel free to reopen if you disagree.

comment:11 Changed 12 years ago by sascha_silbe

Reported at Debian as #519462.

[1] http://bugs.debian.org/

Note: See TracTickets for help on using tickets.