Opened 12 years ago

Closed 12 years ago

#11 closed defect (fixed)

Can not shut down Sugar

Reported by: CarolineM Owned by: marcopg
Priority: blocker Milestone:
Component: Sugar Version:
Severity: Keywords: r+
Cc: caroline@… Distribution/OS:
Bug Status:

Description

The menu items appear to shutdown and restart but they do not work.

This is important for Sugar on a Stick because pulling out the stick while they system is running could lead to corruption.

Attachments (1)

session.patch (690 bytes) - added by marcopg 12 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by erikos

Where do you use sugar? I am able to shutdown fine on sugar/Fedora10 for example.

comment:2 Changed 12 years ago by CarolineM

  • Cc caroline@… added

comment:3 Changed 12 years ago by CarolineM

  • Priority changed from major to blocker

This is a blocker for Sugar on a Stick. It is not a general sugar bug.

comment:4 Changed 12 years ago by marcopg

erikos, interesting. Probably a bug with the livecd then, perhaps caused by the login manager (it might not be initializing ck for example).

comment:5 Changed 12 years ago by marcopg

Two problems here:

  • The login manager is not initializing ck.
  • We fail to shutdown the xsmp session if no activity is open.

comment:6 Changed 12 years ago by marcopg

Real solution for ck will hopefully come out of:

https://bugzilla.redhat.com/show_bug.cgi?id=452156

In the meantime we can hack it around in our xinitrc.

comment:7 Changed 12 years ago by marcopg

Work around pushed to the soas module. Going to look into the xsmp problem now.

Changed 12 years ago by marcopg

comment:8 Changed 12 years ago by marcopg

  • Keywords r? added

The reason we didn't run into this in 8.2 is that Journal was an activity, and hence the session had always at least one client which was disconnected on shutdown.

comment:9 Changed 12 years ago by tomeu

  • Keywords r+ added; r? removed

Looks good, thanks for the nice explanation.

comment:10 Changed 12 years ago by marcopg

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in soas-2 and in git.

Note: See TracTickets for help on using tickets.