Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1044 closed defect (fixed)

weird window behavior for Pippy/Calculate/Colors in Metacity WM

Reported by: walter Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.85.x
Severity: Unspecified Keywords:
Cc: sascha_silbe, sayamindu Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

I am running the latest Jhbuild with the metacity window manager. Pippy exhibits some weird display characteristics. See attached image.

Attachments (1)

pippy-rendering-problem.png (58.9 KB) - added by walter 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by walter

comment:1 Changed 12 years ago by garycmartin

  • Summary changed from weird window behavior for Pippy in Metacity WM to weird window behavior for Pippy/Calculate/Colors in Metacity WM

There are several Activities I've seen so far that display offset and/or incorrectly sized windows (Pippy, Calculate, Colors). I'll have a quick look and see if it's something trivial we could fix in Activity. Most other Activities I've tried so far have been showing up correctly.

comment:2 Changed 12 years ago by garycmartin

  • Version changed from Git as of bugdate to 0.85.x

comment:3 Changed 12 years ago by garycmartin

Also Jigsaw puzzle activity starts at an odd location http://dev.sugarlabs.org/ticket/1130 (reported by Christoph). FWIW I'm still working on a fix for Calculate (but looks like a full rework of layout is needed, not some small tweak).

comment:4 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:5 Changed 12 years ago by garycmartin

  • Cc sayamindu added

comment:6 Changed 12 years ago by sascha_silbe

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 929ce5a3cbf9.

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.