Opened 18 months ago

Closed 18 months ago

Last modified 9 months ago

#4031 closed defect (fixed)

Cant connect to an Access point (Unicode traceback)

Reported by: garycmartin Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: 13.1.0, olpc-test-passed
Cc: dsd Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

In 13.1.0 build 6, trying to connect to an Access Point via the Neighbourhood view fails, generating the below Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/desktop/meshbox.py", line 496, in _ap_props_changed_cb
    self.wireless_networks[old_hash_value].remove_ap(ap)
KeyError: 1462126855
1350156570.050452 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 230, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/sugar/extensions/deviceicon/network.py", line 473, in __ap_properties_changed_cb
    self._update_properties(properties)
  File "/usr/share/sugar/extensions/deviceicon/network.py", line 481, in _update_properties
    self._display_name = network.ssid_to_display_name(self._ssid)
  File "/usr/lib/python2.7/site-packages/jarabe/model/network.py", line 1088, in ssid_to_display_name
    display_name = unicode(ssid, encoding)
TypeError: coercing to Unicode: need string or buffer, dbus.Array found
1350156570.144563 ERROR root: Error getting the wireless device properties: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.3 was not provided by any .service files

Change History (6)

comment:1 Changed 18 months ago by garycmartin

As a temporary quick & dirty hack, I added this one line to get connected for now, likely only works as the ssid's I connect to are plain ascii, no unusual unicode characters:

ssid = str(ssid)
display_name = unicode(ssid, encoding)

comment:2 Changed 18 months ago by tonyforster

see also laptop.org/ticket/12188

comment:3 Changed 18 months ago by garycmartin

Retesting in 13.1.0 build 7, no problem now in connecting to access points. Looks like this can be closed if someone else can confirm.

comment:4 Changed 18 months ago by dsd

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from new to closed

I agree, this was fixed in [PATCH] Request AP properties with dbus ByteArrays (#4031)

Test case: connect to any type of wireless network, check that the tray icon shows that the connection has completed, check that the shell logs don't include this error:

TypeError: coercing to Unicode: need string or buffer, dbus.Array found

comment:5 Changed 18 months ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

We can connect to 802.11 APs in OLPC 13.1.0 os7 and the TypeError message mentioned was not found in any logfiles.

comment:6 Changed 9 months ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.