Opened 2 years ago

Closed 2 years ago

Last modified 16 months ago

#3859 closed defect (fixed)

Sugar scroll bar clicks should invoke page up/page down and not relocate the scroll cursor

Reported by: greenfeld Owned by: erikos
Priority: Urgent Milestone:
Component: Sugar Version: 0.97.x
Severity: Major Keywords: olpc-test-passed
Cc: tonyforster, garycmartin Distribution/OS: OLPC
Bug Status: Assigned

Description

In GNOME- and KDE-style applications (such as Xchat, Firefox, Konqueror, etc.) clicking the vertical scroll bar away from where the the scroll location indicator is results in a page up or page down-style action depending on if the click is above or below the indicator.

In Sugar clicking anywhere the scrollbar is not relocates the scrollable item so that the indicator is moved to the clicked position.

Personally I find this confusing. If one clicks on the scrollbar in Read in a 100+ page document, you can end up far away from where you were, and figuring out how to get back to where you were in an epub book can take a significant amount of time.

In all cases clicking & dragging the scroll indicator relocates it to a desired position.

Seen in 13.1.0 os1.

Attachments (2)

0001-Sugar-scroll-bar-clicks-should-invoke-page-up-page-d.patch (1.3 KB) - added by humitos 2 years ago.
This patch only work in a newer version of Gtk3 (since 3.6) - It works on XO-4 13.1.0 build 8
0001-Invoke-page-up-page-down-on-scrollbars-clicks.patch (1.4 KB) - added by humitos 2 years ago.
Patch for Sugar itself. It's for the Journal

Download all attachments as: .zip

Change History (14)

comment:1 Changed 2 years ago by tonyforster

  • Cc tonyforster added
  • Milestone changed from Unspecified by Release Team to 0.98

added milestone 0.98 so it will come up in searches for that

comment:2 Changed 2 years ago by tonyforster

Still present in OS3, in Browse the cursor is relocated, in Write it advances one page

comment:3 follow-up: Changed 2 years ago by erikos

  • Cc garycmartin added

@gary I think a question for you if we want to change that behavior

comment:4 Changed 2 years ago by erikos

  • Bug Status changed from Unconfirmed to Assigned
  • Priority changed from Unspecified by Maintainer to Normal
  • Version changed from Unspecified to 0.97.x

(marking normal as not a regression)

comment:5 in reply to: ↑ 3 Changed 2 years ago by garycmartin

Replying to erikos:

@gary I think a question for you if we want to change that behavior

Yes we should revert to the old paging behaviour. FWIW with the new behaviour you loose all context of where you were so a scroll bar click is not easily recovered from (in an ebook or pdf you are effectively lost).

comment:6 Changed 2 years ago by erikos

  • Priority changed from Normal to Urgent
  • Severity changed from Unspecified to Major

Sounds like a regression.

comment:7 Changed 2 years ago by humitos

It seems like the buttons are inverted. If you right-click on the scrollbar you get the page up/down. I tested this on Read and Browse on sugar-build.

comment:8 Changed 2 years ago by humitos

This property (gtk-primary-button-warps-slider) has changed between gtk2 and Gtk3:

I tried to set it up when the Activity starts but it says that property does not exist.

>>> from gi.repository import Gtk
>>> settings = Gtk.Settings.get_default()
>>> settings.get_property('gtk-primary-button-warps-slider')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
TypeError: object of type `GtkSettings' does not have property `gtk-primary-button-warps-slider'
>>>

Changed 2 years ago by humitos

This patch only work in a newer version of Gtk3 (since 3.6) - It works on XO-4 13.1.0 build 8

comment:9 Changed 2 years ago by humitos

  • Keywords r? added

Changed 2 years ago by humitos

Patch for Sugar itself. It's for the Journal

comment:10 Changed 2 years ago by erikos

  • Keywords olpc-test-pending added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 2 years ago by greenfeld

  • Keywords olpc-test-passed added; olpc-test-pending removed

Clicking in scrollbars is now much closer to a page-up/page-down action (although not an exact equivalent) in Sugar 0.98.2/OLPC 13.1.0 os20.

comment:12 Changed 16 months ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.