Opened 2 years ago

Closed 20 months ago

Last modified 12 months ago

#3747 closed defect (fixed)

Cannot get Maze to synchronize mazes when joining a shared session

Reported by: greenfeld Owned by: humitos
Priority: Normal Milestone:
Component: Maze Version: 0.96.x
Severity: Unspecified Keywords: r+, olpc-test-pending
Cc: dsd, godiard, manuq, humitos, RafaelOrtiz Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

I cannot get Maze-20 to synchronize mazes when joining a shared session in OLPC 12.1.0 os16 & os17.

No error message is logged but no synchronization seems to occur either.

The collaboration code for Maze was somewhat recently changed in #3296.

Both salut and gabble seem to be affected, and other activities (Chat/Browse/Distance) can share fine under these scenarios.

Attachments (1)

0001-Collaboration-fixed-SL-3747.patch (2.9 KB) - added by humitos 21 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 2 years ago by greenfeld

  • Version changed from 0.95.x to 0.96.x

comment:2 Changed 2 years ago by dsd

  • Cc godiard manuq added

comment:3 Changed 2 years ago by manuq

  • Cc humitos added

comment:4 Changed 2 years ago by humitos

  • Cc RafaelOrtiz added

I'm not sure about how to reproduce this bug, but I'm getting this error:

1342041961.065866 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/sugar/presence/connectionmanager.py", line 89, in __status_changed_cb
    self._connections_per_account[account_path].connected = False
KeyError: dbus.ObjectPath('/org/freedesktop/Telepathy/Account/gabble/jabber/_39de609952c94db17cbd7880564fb5b73233543df_400')

and this one too:

1342041969.678904 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/sugar/presence/connectionmanager.py", line 67, in __account_property_changed_cb
    self._track_connection(account_path, properties['Connection'])
  File "/usr/lib/python2.7/site-packages/sugar/presence/connectionmanager.py", line 72, in _track_connection
    connection = bus.get_object(connection_name, connection_path)
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Telepathy.Connection.gabble.jabber._39de609952c94db17cbd7880564fb5b73233543df_40jabber_2esugarlabs_2eorg_2fsugar was not provided by any .service files

I don't have too much experience with collaboration and dbus, maybe another person could help us. Could it be related with sugar itself? I'm asking this because we didn't touch the collaboration code after the work done in the ticket mentioned on the description.

comment:5 Changed 23 months ago by RafaelOrtiz

this errors are affecting the maze-collab-sharing experience.

comment:6 Changed 22 months ago by RafaelOrtiz

v18 doesn't have this error Btw.

comment:7 Changed 21 months ago by manuq

  • Milestone changed from Unspecified by Release Team to 0.98
  • Owner changed from RafaelOrtiz to humitos
  • Status changed from new to assigned

Changed 21 months ago by humitos

comment:8 Changed 21 months ago by humitos

  • Keywords r? added

comment:9 Changed 21 months ago by humitos

I tested this patch between:

  • XO 1.5 (13.1.0 os9 - compiled git version of sugar) + XO 1.5 (13.1.0 os10 - compiled git version of sugar)
  • same scenario + XO 1.75 (12.1.0 os21)

I used all the player in each XO, so I have 9 players playing in the same board.

comment:10 Changed 20 months ago by godiard

  • Priority changed from Unspecified by Maintainer to Normal

comment:12 Changed 20 months ago by humitos

  • Keywords olpc-test-pending added
  • Resolution set to fixed
  • Status changed from assigned to closed

This is available on Maze-22

comment:13 Changed 20 months ago by humitos

  • Keywords r+ added; r? removed

comment:14 Changed 12 months ago by dnarvaez

  • Milestone 0.98 deleted

Milestone 0.98 deleted

Note: See TracTickets for help on using tickets.