Opened 2 years ago

Closed 6 months ago

#3626 closed defect (duplicate)

Browse copy image function not linked into Sugar's copy/paste sidebar

Reported by: greenfeld Owned by: manuq
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords: 12.1.0
Cc: humitos Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

  1. Start Browse (Webkit-based).
  2. Go to a web page/home page with images.
  3. Right click on an image and choose "Copy image".
  4. The image will be copied to the X clipboard, and can be pasted into applications like Write; but no notification appears that the image has been copied into Sugar's clipboard, and the available clipboard selections (if any) in the left section of the Sugar frame are not altered.

Text-based selections in Browse seem to use Sugar's copy/paste interface.

Seen in OLPC 12.1.0 os11/Browse-137.

Change History (8)

comment:1 Changed 2 years ago by manuq

This seems a consequence of #3455 .

comment:2 Changed 2 years ago by manuq

  • Keywords 12.1.0 added
  • Milestone changed from Unspecified by Release Team to 0.96
  • Owner changed from erikos to manuq
  • Status changed from new to assigned

comment:3 Changed 2 years ago by humitos

  • Cc humitos added

comment:4 follow-up: Changed 2 years ago by humitos

Documentation about how to use the clipboard:

comment:5 in reply to: ↑ 4 Changed 2 years ago by manuq

Replying to humitos:

Documentation about how to use the clipboard:

The code is already there in the Sugar palette, we're having trouble displaying it, see #3455 .

comment:6 Changed 22 months ago by manuq

  • Milestone changed from 0.96 to 1.0

comment:7 Changed 12 months ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

comment:8 Changed 6 months ago by manuq

  • Milestone set to Unspecified
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #3455, which is fixed.

Note: See TracTickets for help on using tickets.