Opened 3 years ago

Closed 6 weeks ago

#3027 closed defect (fixed)

Problems with two active instances

Reported by: dsd Owned by: dsd
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Record Version: Unspecified
Severity: Unspecified Keywords:
Cc: walter Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Even with the code that I just pushed to master which releases the audio/camera when the activity is no longer active, you cannot switch directly between 2 instances of the Record activity. The second one does not "win" the camera as it should.

I suspect this is because the events are not being delivered int he right order (is the 2nd instance being told that it is visible before the 1st instance is told that it is obscure?), or that simply not enough time is left for the first one to release the resources before the second instance picks them up (not really sure how this is supposed to work).

Also see #2570 which must be fixed before we have a smooth multiple-instances experience.

Change History (3)

comment:1 Changed 2 years ago by walter

We bumped into the issue at the Holmes Camp this week. Kids had multiple instances of Record open, not from design (in fact, I am not sure how they did it. Does Record not default to "start most recent? In any case, it caused lots of confusion. Unless there is a compelling use case for a multi-instances experience, I'd advice we make only one instance of Record available at any one time.

comment:2 Changed 2 years ago by walter

  • Cc walter added

comment:3 Changed 6 weeks ago by paulcotton

  • Resolution set to fixed
  • Status changed from new to closed

This appears to be fixed.

Note: See TracTickets for help on using tickets.