Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#953 closed defect (wontfix)

No networking in Classmate

Reported by: davidjim Owned by: sdz
Priority: High Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: 0.84.x
Severity: Critical Keywords: classmate
Cc: Distribution/OS: Unspecified
Bug Status: Resolved

Description

Soas doesn't identify the wireless card of the intel classmate.

Change History (15)

comment:1 Changed 12 years ago by SeanDaly

My Gen1 Classmate (Olidata JumPc 7" screen 2 Gb SSD) successfully burned its own SoaS snapshot last night with Fedora LiveUSB Creator under Windows, then booted Sugar from it and with wired LAN connection joined the jabber testing session. However, all local wifi networks were shown in the Neighborhood View; AFAICT wireless card recognized.

What generation, make & model of Intel Classmate?

comment:2 Changed 12 years ago by davidjim

It is an Intel Classmate Third Generation 7", I've also done that, but it doesn't detect the wireless, its a 802.11 USB Wireless LAN Card (internal)

comment:3 Changed 12 years ago by davidjim

please, somebody post something, I believe this is critical.

comment:4 Changed 12 years ago by SeanDaly

http://www.classmatepc.com/where-to-buy/convertible/tech-specs/

The Gen3 Classmate is the "Convertible", with 8.9" 1024x600 swivel touchscreen, is yours that one?
Gen1 "Clamshell" is with 7" 800x480 screen (some Control Panel parms unavailable due to this small screen see #868), Gen2 "Clamshell" is with 8.9" 1024x600 screen.

comment:5 Changed 12 years ago by davidjim

Thanks!, mine is the one with gravity sensors.

comment:6 Changed 12 years ago by RafaelOrtiz

  • Keywords classmate added

It seems that the networking in the CM2 works but in the CM3 or convertible doesn't.
i don't know the wireless card on the CM3 so i can't comment but it might need some additional tuning under linux in order to work.

comment:7 Changed 12 years ago by davidjim

The card that de Classmate Gen 3 uses is a 802.11n Wi-Fi via Ralink RT3070 (USB), you can see the properties in: http://techreport.com/articles.x/16496/2

comment:8 Changed 12 years ago by davidjim

i'm kind of lost here, i've found the sources of the rt3070 driver for linux, but i can't build it in the sugar's terminal (soas), i yum the gcc, make, and kernel-devel, but the last one is from a newer kernel, i dont see or know the correct way to change the kernel version that soas choose to boot.

comment:9 Changed 12 years ago by daveb

Using Soas-strawberry
Try this in terminal

su -

su -c 'rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm'

yum install kmod-rt3070

Then reboot. The wireless should be detected and work.

comment:10 Changed 12 years ago by davidjim

hi dav eb, i did what you said, reboot and nothing. Also tried with the akmod-rt3070, but nothing. Am i missing some instruction to bring up the wireless?

comment:11 Changed 12 years ago by daveb

Worked on this in IRC.

Fedora or rpmfusion has a newer kernel. Its picking that up and installing the wireless driver for the newer kernel.

You can work around this by specifying the kernel when calling yum ie:

yum install kmod-rt3070-2.6.29.4-167.fc11.i586

This gets the one that matches your kernel.

comment:12 Changed 12 years ago by davidjim

thanks!! that solved the problem =), can you add this driver to the next release?

comment:13 Changed 12 years ago by wadeb

  • Milestone changed from 0.84 to Unspecified by Release Team

Not Sugar milestone related. Feel free to add a SoaS milestone if appropriate. Sounds like that package ought to make it into our kickstart if it hasn't already.

BTW you can always do this to get the right version of a kernel package:

yum install kmod-rt3080-uname -r

Or for kernel-devel:

yum install kernel-devel-uname -r

comment:14 Changed 11 years ago by sdz

  • Bug Status changed from Unconfirmed to Resolved
  • Resolution set to wontfix
  • Status changed from new to closed

There's nothing we can do about this, since we're following Fedora's policies concerning the inclusion of software. In case this gets into the official kernel, it'll be supported though. Until then, manually installing the kernel mods from RPM Fusion is probably the individual way to go.

comment:15 Changed 11 years ago by sascha_silbe

  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

Note: See TracTickets for help on using tickets.