Opened 10 years ago

Closed 5 years ago

#946 closed enhancement (wontfix)

Can not download image when opened in a popup

Reported by: erikos Owned by: humitos
Priority: Low Milestone: Unspecified
Component: Browse Version: 0.84.x
Severity: Minor Keywords:
Cc: manuq, humitos, godiard, erikos Distribution/OS: Unspecified
Bug Status: New

Description

When the image is opened in a popup (zoom) I can not get a palette to download it.

Change History (17)

comment:1 Changed 10 years ago by erikos

Most of the zoomed images open now in a new tab. Only the screenshots in activities.sugarlabs.org do not. In firefox one can only get at the image with: "view background image" and then save the image - which is not straightforward neither.

comment:2 Changed 10 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from 0.86 to 0.88
  • Type changed from defect to enhancement

comment:3 Changed 9 years ago by walter

  • Milestone changed from 0.88 to 0.90

As noted, this is painful in all browsers. Maybe 0.90?

comment:4 Changed 8 years ago by RafaelOrtiz

  • Milestone changed from 0.90 to 0.94

Moving to 0.94

comment:5 Changed 7 years ago by manuq

  • Milestone changed from 0.94 to 0.96

Related: #3455 .

comment:6 Changed 7 years ago by manuq

  • Cc manuq added

comment:7 Changed 7 years ago by erikos

  • Milestone changed from 0.96 to 0.98

Not a regression, moving out.

comment:8 Changed 7 years ago by humitos

  • Cc humitos added
  • Priority changed from Unspecified by Maintainer to High

Setting priority because it's important.

comment:9 Changed 7 years ago by humitos

  • Priority changed from High to Normal

Well, this should be done by looking if the property background-image exists in the element clicked.

For example, the actual code for http://activities.sugarlabs.org to show the screenshot images is like:

<div id="lbImage" style="background-image: url(http://activities.sugarlabs.org/en-US/sugar/images/p/5/1235687644); display: block; ">
    <div style="position: relative; width: 700px; height: 525px; ">
        <a id="lbPrevLink" href="#" style="display: none; height: 525px; "></a>
        <a id="lbNextLink" href="#" style="display: none; height: 525px; "></a>
    </div>
</div>

Changing the priority, this is no so important. It's just one specific case.

comment:10 Changed 7 years ago by humitos

  • Cc godiard erikos added

This is the code we should use to look for background-image property, but we have to go throughout the DOM (from the inside to the top of it) to look that style property.

In the example given in the previous comment, when I click over the image I get the "inner div", so I have to ask for the parent of it to check the background-image property:

>>> element = hit_test.props.inner_node
>>> element.props.style.get_css_text()
'position: relative; width: 700px; height: 525px; '
>>> element.get_parent_element().props.style.get_css_text()
'background-image: url(http://activities.sugarlabs.org/en-US/sugar/images/p/5/1235687644); display: block; '

So, do we want to make that check recursively to check that property? how deep do we want to make it?

comment:11 Changed 7 years ago by humitos

  • Owner changed from erikos to humitos
  • Status changed from new to accepted

comment:12 Changed 7 years ago by dsd

The other consideration to keep in mind is that we will lose DOM access in WebKit2. Might be worth looking at if/how epiphany will cope with this, and/or start some discussion on webkit-gtk list.

comment:13 Changed 7 years ago by humitos

  • Priority changed from Normal to Low

comment:14 Changed 7 years ago by humitos

  • Milestone changed from 0.98 to 1.0

comment:15 Changed 6 years ago by manuq

No other browser is behaving like this. We already make a good job with palettes for images since #4262. I would say won't fix.

comment:16 Changed 6 years ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

comment:17 Changed 5 years ago by godiard

  • Milestone set to Unspecified
  • Resolution set to wontfix
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.