Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#908 closed defect (duplicate)

Speak has garbage sound on latest Soas then crashes

Reported by: NoiseEHC Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

Speak has garbage sound on latest Soas appliances with VirtualBox (20090524 and 20090528), if I change something (like the mouth) then it fixes the sound for a small time then it becomes garbage again.
Then it crashes with this:

/usr/lib/python2.6/site-packages/sugar/util.py:25: DeprecationWarning: the sha module is deprecated; use the hashlib module instead

import sha

1243646011.870168 WARNING root: No gtk.AccelGroup in the top level window.
1243646011.885295 WARNING root: No gtk.AccelGroup in the top level window.

/usr/lib/python2.6/site-packages/sugar/graphics/window.py:120: GtkWarning: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container)
widget->parent == GTK_WIDGET (container)' failed

self._vbox.remove(self.toolbox)

(sugar-activity:1799): DEBUG: Got client ID "10e842a8948e72b2eb124364601226111800000016640001"
(sugar-activity:1799): DEBUG: Setting initial properties
(sugar-activity:1799): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
(sugar-activity:1799): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
(sugar-activity:1799): DEBUG: Received SaveComplete message in state save-yourself-done
python: pcm_pulse.c:361: pulse_write: Assertion `pcm->stream' failed.
Best voice for LANG en_US.UTF-8 seems to be en Default

Change History (6)

comment:1 Changed 11 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Component changed from SoaS to Speak
  • Distribution/OS changed from Unspecified to SoaS
  • Owner changed from sdz to jminor

This occurs for me with soas-strawberry-vdi in VirtualBox2.2.4 on a Jackalope64 host. On a Vista32 host I had no sound.

comment:2 Changed 11 years ago by RafaelOrtiz

this seems like a problem of the gst-plugins-espeak plugin for gstreamer or something related to gstreamer ?

comment:3 Changed 11 years ago by alsroot

  • Bug Status changed from New to Needinfo

for me it looks like pulseaudio issue, it could be checked by removing pulse from system and using pure alsa

comment:4 Changed 11 years ago by alsroot

  • Owner changed from jminor to alsroot
  • Status changed from new to assigned

comment:5 Changed 11 years ago by alsroot

  • Resolution set to duplicate
  • Status changed from assigned to closed

dup of #1140

comment:6 Changed 11 years ago by sascha_silbe

  • Component changed from Speak to SoaS
  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

Note: See TracTickets for help on using tickets.