Opened 12 years ago

Closed 9 years ago

Last modified 8 years ago

#893 closed enhancement (wontfix)

Show multimedia tile to support text formats

Reported by: tonyforster Owned by: walter
Priority: Normal Milestone:
Component: Turtleart Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Enhance the show multimedia tile to support as many formats as possible including txt, doc, pdf etc.

Attachments (1)

TurtleArt-104.xo (998.0 KB) - added by walter 10 years ago.
added simple RTF support to show block

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by walter

more fine-tuning suggestions from Tony...

One (of probably many) inconsistency: I use scale for all show media
except text, for which I have set-text-size (and set-text-color)
blocks on the Pen palette. Maybe it should scale relative to the
current text size?

Doesnt worry me, once I realised that scale just applied to show I was happy.

Related issue is the labelling and grouping on the tabs:

hideblocks might be better on the turtle tab with clean

is multimedia show better on the templates tab? are all the templates needed if we now have multimedia show?

does print belong on the numbers tab, maybe turtle or redbox?

Redbox tab label "keyboard" is misleading, other or extra?

hover tips or right click tips a good enhancement?

comment:2 Changed 12 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

I think the hideblocks is really only relevant to slideshows, hence it is on the templates palette.

The show brick is of general utility, so I think it should stay on the Turtle palette.

I don't have strong feelings about print, so I think I'll leave it where it is.

I renamed Keyboard to Extras as per your suggestion.

Hover is being handled in a separate ticket (by rgs)

comment:3 Changed 12 years ago by walter

  • Milestone changed from Unspecified by Release Team to 0.88
  • Resolution fixed deleted
  • Status changed from closed to reopened

oops. reopening because I still need to add provisions for txt and pdf as per the original ticket.

comment:4 Changed 11 years ago by walter

  • Milestone changed from 0.88 to 0.90

there is more work to do re formating which I will defer to 0.90, but .txt, .py, and .lg files will open with the show block.

comment:5 Changed 10 years ago by walter

Version 104 now has support for .rtf. Still need to do .doc and .odt.

Changed 10 years ago by walter

added simple RTF support to show block

comment:6 Changed 9 years ago by walter

  • Resolution set to wontfix
  • Status changed from reopened to closed

I don't see the use case for adding additional formats. Will reopen if a compelling use case is proposed.

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.