Opened 11 years ago

Closed 10 years ago

#887 closed enhancement (fixed)

Sugarize Tux Paint

Reported by: CarolineM Owned by: tvoverbeek
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: TuxPaint Version: Unspecified
Severity: Unspecified Keywords: GPA
Cc: alsroot, sascha_silbe Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Make it share and use the Journal

Change History (10)

comment:1 Changed 11 years ago by alsroot

  • Component changed from sugar to TuxPaint
  • Owner changed from tomeu to alsroot
  • Status changed from new to assigned
  • Type changed from defect to enhancement

comment:2 follow-up: Changed 11 years ago by luce_quilla

Hello. I'm working on a proyect in Mexico and we are using Tux Paint in our activities. I would like to see the activity in my journal and to be able to share it. I wanted to know how you are doing with the problem and an estimation of when this will be solved. Thanks.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 11 years ago by alsroot

Replying to luce_quilla:

Hello. I'm working on a proyect in Mexico and we are using Tux Paint in our activities. I would like to see the activity in my journal and to be able to share it. I wanted to know how you are doing with the problem and an estimation of when this will be solved. Thanks.

sharing is really hard problem(since Tuxpaint was written in plane C)

about using Journal to store paints, it shouldn't be a problem and I'm planing to implement it until July, 15

comment:4 Changed 11 years ago by alsroot

  • Owner changed from alsroot to tvoverbeek

so, I delegated this ticket to Ton :)

comment:5 Changed 11 years ago by alsroot

  • Cc alsroot added

comment:6 in reply to: ↑ 3 Changed 11 years ago by tomeu

Replying to alsroot:

Replying to luce_quilla:

Hello. I'm working on a proyect in Mexico and we are using Tux Paint in our activities. I would like to see the activity in my journal and to be able to share it. I wanted to know how you are doing with the problem and an estimation of when this will be solved. Thanks.

sharing is really hard problem(since Tuxpaint was written in plane C)

Why so hard? Abiword and Etoys use the D-Bus API and AFAIK this wasn't such a big deal.

comment:7 Changed 11 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:8 Changed 11 years ago by tvoverbeek

Since I volunteered to start implementing this, any pointers to the low level dbus API for the journal are appreciated. I am aware of the low level api pages om wiki.laptop.org but have no idea how up to date it is since it was written (by Bert Freudenberg I believe) when doing the initial Etoys port.
Pointers to the appropriate source code repositories for Etoys and/or Abiword are also appreciated.

comment:9 Changed 11 years ago by gregorio

  • Keywords GPA added

Did anyone get back to Tan on this?

There's movement on the Paint program too but Tux paint has a lot of advantages if it can be made to share, Keep etc per Sugar's overall guidelines.

Thanks,

Greg S

comment:10 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from assigned to closed

Last v4 has Journal integration.
http://activities.sugarlabs.org/en-US/sugar/addons/versions/4088#version-4
It is an experimental activity since it is pure binary based.

Note: See TracTickets for help on using tickets.