Opened 13 years ago

Closed 13 years ago

#884 closed defect (notsugar)

instructions for jhbuild on Fedora 10 x86_64 not working

Reported by: jerry Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Unspecified
Severity: Unspecified Keywords: dev install x86_64 FC10
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

http://wiki.sugarlabs.org/go/Development_Team/Jhbuild

shows a process with git to download and install a development version of sugar

git clone git://git.sugarlabs.org/sugar-jhbuild/mainline.git sugar-jhbuild

cd sugar-jhbuild
./sugar-jhbuild update
./sugar-jhbuild depscheck

Missing packages:
libffi-devel

=====> and can't get to ./sugar-jhbuild build

but http://magazine.redhat.com/2007/02/23/building-the-xo-introducing-sugar/ shows a similar but much older (2007?) process.

Anyway, libffi giving a conflict with g-wrap-devel
on FC10 x86_64 which I can't get around... Not sure if they changed package names or what...

yum install libffi-devel
gives:
Transaction Check Error:

file /usr/lib64/libffi.so from install of libffi-devel-3.0.5-1.fc10.x86_64 conflicts with file from package g-wrap-devel-1.9.9-7.fc10.x86_64

I'd like to try a devel version of sugar before Fedora 11 comes out in a week or so, and not sure what the package issue is, so thought someone else might want to know, hence creating a ticket.

Change History (1)

comment:1 Changed 13 years ago by sascha_silbe

  • Resolution set to notsugar
  • Status changed from new to closed

The file conflict is something you have to report to Fedora, we cannot do anything about it unfortunately (that's the reason I'm rejecting this bug).

I don't know which package needs libffi (was added as a dependency before I took over maintainence), so maybe you can still build enough of Sugar to do some tests. "build" will not check dependencies so it doesn't prevent you from continuing even if not all dependencies are installed.
Another option (if you don't need the application depending on it for daily use) is to uninstall g-wrap while testing Sugar.

Note: See TracTickets for help on using tickets.