Opened 12 years ago

Closed 12 years ago

#857 closed defect (fixed)

Obsolete jhbuild start script

Reported by: Mokurai Owned by: bernie
Priority: High Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Blocker Keywords:
Cc: morfila@…, sascha_silbe Distribution/OS: Unspecified
Bug Status: New

Description

I have compiled and run sugar-jhbuild on other Linux distributions with varying success. This is the first time I couldn't compile anything. Steps 1-5 seemed to work as expected. Steps 6 and 7 ran but produced an unexpected error message, which I don't understand. Step 7 failed completely.

  1. Install Fedora 10 in VirtualBox from downloaded image.
  2. sudo yum update
  3. Install prerequisites listed on Development_Team/Jhbuild/Fedora
  4. git clone git://git.sugarlabs.org/sugar-jhbuild/mainline.git sugar-jhbuild
  5. cd sugar-jhbuild
  6. ./sugar-jhbuild update

At end of run, says

sugar-jhbuild: Obsolete jhbuild start script, do run 'make install'

  1. ./sugar-jhbuild depscheck

Updating sugar-jhbuild...
Already up-to-date.
Updating upstream jhbuild...
Already up-to-date.
sugar-jhbuild: Obsolete jhbuild start script, do run 'make install'

  1. /sugar-jhbuild build

sugar-jhbuild: Obsolete jhbuild start script, do run 'make install'

Change History (11)

comment:1 Changed 12 years ago by Mokurai

Sorry, step 8 failed completely.

comment:2 Changed 12 years ago by morfila

  • Cc morfila@… added
  • Component changed from sugar to sugar-jhbuild
  • Owner changed from tomeu to sascha_silbe
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Blocker

I'm having the same problem in Ubuntu 9.04 with the latest updates and Ubuntu 8.10 either just installed (without updates) and with the latest updates.

It used to work in Ubuntu 8.10, I was using it some time ago (one or two months ago).

As far as I can see, in file "jhbuild/jhbuild/config.py", the following "try-except" fails:

try:

SRCDIR

except NameError:

raise FatalError(_('Obsolete jhbuild start script, do run \'make install\))

It seems that SRCDIR is not defined. Where should it be defined?
Here's the ouptut of a search for string "SRCDIR":

=[ BEGIN find ]============================================
morfila@morfila-laptop:~/ceibaljam/sugar/sugar-jhbuild$ find . -type f -name '*.py' -exec grep -H SRCDIR {} \;
./jhbuild/tests/tests.py:builtin.dictSRCDIR? = os.path.join(os.path.dirname(file), '..')
./jhbuild/tests/tests.py:sys.path.insert(0, SRCDIR)
./jhbuild/jhbuild/moduleset.py: moduleset_local_path = os.path.join(SRCDIR, 'modulesets')
./jhbuild/jhbuild/commands/bot.py: basedir = os.path.join(SRCDIR, 'buildbot')
./jhbuild/jhbuild/versioncontrol/hg.py: if os.path.exists(SRCDIR):
./jhbuild/jhbuild/versioncontrol/hg.py: hg_update_path = os.path.join(SRCDIR, 'scripts', 'hg-update.py')
./jhbuild/jhbuild/versioncontrol/tarball.py: os.path.join(SRCDIR, 'patches', patch)):
./jhbuild/jhbuild/config.py: SRCDIR
morfila@morfila-laptop:~/ceibaljam/sugar/sugar-jhbuild$
=[ END find ]==============================================

The addition of SRCDIR into "builtin" should be enough,
but it seems it's not working.

Regards,

Marcos

comment:3 Changed 12 years ago by mcbrighton

I get the same result on fresh installs of both Ubuntu 8.10 and Fedora 10.

comment:5 in reply to: ↑ 4 Changed 12 years ago by morfila

It happens with a fresh install of Debian 5.0 two.
In the bugzilla ticket it says it is resolved :-(

comment:6 Changed 12 years ago by RafaelOrtiz

this patch fixes the problem

http://bugzilla.gnome.org/attachment.cgi?id=135004&action=view

has to be applied to sugar-jhbuild script.

comment:7 Changed 12 years ago by erikos

Fix does work for me as well - Sascha do you want to have a last look at it and commit then?

comment:8 Changed 12 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Keywords r? added; jhbuild removed
  • Version changed from Unspecified to Git as of bugdate

comment:9 Changed 12 years ago by garycmartin

Fab, fix is also working well here on my F10 based, sugar-jhbuild VirtualBox Mac environment. FWIW I did have one other issue I had to manually fix before I could successfully build, the error was:

*** Building sugar-update-control *** [22/37]
python setup.py build
Traceback (most recent call last):
  File "setup.py", line 2, in <module>
    from DistUtilsExtra.command import * # gettext support
ImportError: No module named DistUtilsExtra.command

I re-tried:

	./sugar-jhbuild depscheck

...but this gave no indication that the module was needed, or missing, so I manually installed it with:

	sudo yum install python-distutils-extra

Build was all happy after this.

comment:10 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added
  • Distribution/OS changed from Fedora to Unspecified
  • Keywords r? removed
  • Owner changed from sascha_silbe to bernie
  • Status changed from new to assigned

Just pushed the fix I did on saturday, it's essentially the
same as the one tagged for review. I have not yet fixed all
other issues (e.g. the do_checkout on MetaModule backtrace),
though.
I'm still in bed with the nasty cold I imported from Paris.
Bernie, could you have a look at it, please?

comment:11 Changed 12 years ago by bernie

  • Resolution set to fixed
  • Status changed from assigned to closed

Works for me, thanks!

Note: See TracTickets for help on using tickets.