Opened 12 years ago

Closed 8 years ago

#846 closed defect (fixed)

Chat: can't copy from chat messages

Reported by: martin.langhoff Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Chat Version: Git as of bugdate
Severity: Major Keywords: sugar-love
Cc: sascha_silbe, tonyforster Distribution/OS: Unspecified
Bug Status: New

Description

Using soas 200905031329

There is no way to select text from other users' messages. Can't share debugging info over chat during a testing session :-(

Change History (7)

comment:1 Changed 12 years ago by alsroot

  • Owner changed from morgs to alsroot
  • Status changed from new to assigned

comment:2 Changed 11 years ago by sdz

  • Milestone soas_fossvt deleted

Milestone soas_fossvt deleted

comment:3 Changed 11 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Cc sascha_silbe added
  • Milestone set to Unspecified by Release Team
  • Severity changed from Unspecified to Major
  • Version changed from Unspecified to Git as of bugdate

comment:4 Changed 11 years ago by cjl

See http://dev.laptop.org/ticket/8472

Regarding an older version morgs said: "This is a problem in hippo-canvas. We might migrate Chat's UI to plain GTK at some point (which would fix this) - the main issue is the nice roundboxes that hippo gives us. "

comment:5 Changed 10 years ago by tonyforster

  • Cc tonyforster added

Added myself to cc

Hope to raise the priority for this issue. See this as a major blocker in effective distance collaboration.

Speak with chat text to speech will be very handy, particularly if you are not in the same place, this is because in fullscreen, its a very good way to communicate while sharing an Activity. You get an alert while the shared Activity stays full screen. Its then the logical way to share text fragments rather than running a parallel Write session.

I am presuming that text to speak chat in Speak will also inherit this behaviour from Chat.

comment:6 Changed 10 years ago by alsroot

  • Keywords sugar-love added

Speak activity uses a widget from Chat, it will be useful if someone will implement text selection feature there (most likely it will mean switching this widget to pure gtk from hippo-canvas), later it might be reused in Chat.

comment:7 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

Chat was already ported to Gtk widgets, and now we can copy from the text from another user. A limitation is we can only copy one block (rounded box) at time.

Note: See TracTickets for help on using tickets.