Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#835 closed defect (wontfix)

Soas-20090503 with helper cd, no wireless on Macbook

Reported by: daveb Owned by: sdz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: 0.84.x
Severity: Unspecified Keywords:
Cc: bernie Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Wireless does not work with soas-20090503 with helper CD.

Change History (11)

comment:1 Changed 12 years ago by daveb

It's the classic broadcom chipset unfortunately

It seems to say it is using some kernel module but iwconfig says no wireless extensions.
Here is lspci output

02:00.0 Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03)

Subsystem: Apple Computer Inc. Device 0088
Physical Slot: 4
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at 90500000 (64-bit, non-prefetchable) [size=16K]
Memory at 90000000 (64-bit, prefetchable) [size=1M]
Capabilities: [40] Power Management version 2
Capabilities: [58] Vendor Specific Information <?>
Capabilities: [e8] MSI: Mask- 64bit+ Count=1/1 Enable-
Capabilities: [d0] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [13c] Virtual Channel <?>
Capabilities: [160] Device Serial Number 1e-00-b0-ff-ff-c2-26-d2
Capabilities: [16c] Power Budgeting <?>
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb

comment:2 Changed 12 years ago by daveb

Still doesn't work on 20090524. This is important for some users, is there a way to support these common wireless chipsets?

comment:3 Changed 12 years ago by daveb

Also, for completeness, this is the same result with F11 Preview LiveCD. I don't know if there are rpmfusion drivers for this chipset, I'll check it out.

comment:4 Changed 12 years ago by daveb

Looks like broadcom is supported in rpmfusion non-free which is redistributable but not modifiable.

comment:6 Changed 12 years ago by bernie

The bcm43xx chipset is supported by the Linux kernel shipped with Fedora, but the firmware is not redistributable, therefore it is not included in the distribution.

To install it, do the following (untested):

 sudo -i # or su -
 yum install b43-fwcutter
 wget http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
 tar xjf broadcom-wl-4.150.10.5.tar.bz2
 b43-fwcutter -w /lib/firmware broadcom-wl-4.150.10.5/driver/wl_apsta_mimo.o

The procedure is explained in full detail here:

http://www.linuxwireless.org/en/users/Drivers/b43

comment:7 Changed 12 years ago by bernie

  • Cc bernie added

comment:8 Changed 12 years ago by tomeu

  • Component changed from sugar to SoaS
  • Owner changed from tomeu to sdz

comment:9 Changed 11 years ago by RafaelOrtiz

anyone has a mac to test this out ? (and fix it hopefully;))

comment:10 Changed 11 years ago by daveb

  • Resolution set to wontfix
  • Status changed from new to closed

You can use the broadcom driver in RPMfusion which is free. This depends greatly on exactly which model of the Broadcom chipset you have, dependent on the Macbook model.

The package is called broadcom-wl in RPMfusion non-free. It is free to redistribute but not to modify.

Since it is SoaS policy to only include Fedora packages I am resolving this. You can get the driver if you want using the fwcutter or the RPMfusion STA driver.

comment:11 Changed 11 years ago by sascha_silbe

  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

Note: See TracTickets for help on using tickets.