Opened 11 years ago

Closed 7 years ago

Last modified 7 years ago

#833 closed enhancement (wontfix)

Check box in Sugar control panel to turn off/on jabber without removing server name

Reported by: satellit Owned by: tomeu
Priority: Normal Milestone:
Component: Sugar Version: Unspecified
Severity: Minor Keywords: jabber network panel
Cc: garycmartin, Eben, HoboPrimate, TylerB, dfarning Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Put a check box to activate/deactivate jabber without a reboot
There are times local networking is all that is needed. It would
save loading on jabber servers. Also would permit exchange of items
between locally connected students

Change History (10)

comment:1 Changed 11 years ago by tomeu

  • Cc garycmartin Eben HoboPrimate added

Note that by setting the jabber server name to a non-existent one will have the same effect. But I guess we should anyway have a more obvious way to do the same.

Eben, Gary, Eduardo, could you comment?

comment:2 Changed 11 years ago by satellit

see #830
Sugar Desktop installed in Fedora 11 at 800x600 resolution only shows network window down to "Collaboration" Needs slider bar on window. Cannot change Jabber server unless use command line in terminal. Being able to shut off jabber without booting would mean less load on jabber when not needed.

comment:3 Changed 11 years ago by garycmartin

I can imagine several possible steps depending on the overall aim:

1) Add a standard (x) clear field button to the input field (as found in the search input field), this would just make clearing the server name more obvious and easy – would be a nice detail hint if an empty server input box displayed a greyed out text string stating something like 'using local collaboration'.

2) Give the server field a history/autocomplete, so it's easy to pull back a previous collaboration server name. Bonus points for allowing the history to be easily pre-seeded by a deployment so a school may add some valid alternative server names for easier switching.

3) Servers are currently used a little like the discussed group feature, where different communities have their own server and switch between several depending who they are working with. This is a simple way to scale/isolate working groups for those able to set-up a collaboration server. If this is seen as a valid future work flow case it may be worth exposing the current server name, and history of others, in the Neighbourhood toolbar for quick and easy switching.

FWIW, option 3 could be a replacement for the group feature, especially when combined with a buddy tagging scheme; where buddy tagging would allow easy/quick ad-hoc filtering of a server's participants, and multiple servers (or virtual server hosts) act as way to scale and switch to completely different working groups.

comment:4 Changed 11 years ago by sascha_silbe

  • Cc TylerB dfarning added

Adding reporter and CC from dupe bug #1163.

comment:5 Changed 11 years ago by tomeu

  • Milestone changed from Unspecified by Release Team to 0.88
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor
  • Type changed from defect to enhancement

comment:6 Changed 11 years ago by sascha_silbe

  • Summary changed from Check box in Sugar control panel to turn off/on jabber without booting to Check box in Sugar control panel to turn off/on jabber without removing server name

comment:7 Changed 11 years ago by garycmartin

  • Milestone changed from 0.88 to 0.90

Pushing out to 0.90. Think we need some design agreement on where/how this UI should go, seems to link in with ideas about allowing misc telepathy users@server to be added to the roster (from a UI perspective).

comment:8 Changed 11 years ago by tomeu

Agreed, each account would have an Enable checkbox: #476

comment:9 Changed 7 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed

Old enancement request which doesn't feel particuilarly critical and it's not of trivial solution. Patches welcome.

comment:10 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.