Opened 10 years ago

Closed 5 years ago

#800 closed enhancement (fixed)

Set audio capture volumes

Reported by: alsroot Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Unspecified Keywords:
Cc: eben Distribution/OS: Unspecified
Bug Status: New

Description


Change History (14)

comment:1 Changed 10 years ago by tomeu

  • Cc eben added

Eben, how would we do this one?

comment:2 follow-up: Changed 10 years ago by eben

What are we trying to do? Is this for Record? There's no description...

comment:3 in reply to: ↑ 2 Changed 10 years ago by tomeu

Replying to eben:

What are we trying to do? Is this for Record? There's no description...

Don't think it's activity specific, just a way to set the capture volume.

comment:4 follow-up: Changed 10 years ago by eben

I'm not understanding why its necessary to have any UI for this, though. Wouldn't this only matter when an activity (for instance, Record) is attempting to use the mic, in which case we could have a standard default and that activity could have a gain slider or similar for adjusting it in context?

Another alternative, if we do want to expose this globally, is to add it to settings, and/or have a gain slider in the mic device palette (once we have mic/camera devices in the Frame). Creating those devices and having them change from outline to fill based on the state of the camera an mic would be great!

comment:5 in reply to: ↑ 4 ; follow-up: Changed 10 years ago by tomeu

Replying to eben:

I'm not understanding why its necessary to have any UI for this, though. Wouldn't this only matter when an activity (for instance, Record) is attempting to use the mic, in which case we could have a standard default and that activity could have a gain slider or similar for adjusting it in context?

Another alternative, if we do want to expose this globally, is to add it to settings, and/or have a gain slider in the mic device palette (once we have mic/camera devices in the Frame). Creating those devices and having them change from outline to fill based on the state of the camera an mic would be great!

Maybe we should have those controls in the device side of the frame. I think people right now are a bit disoriented because an activity can lower and mute the capture device and other activities cannot record any more. A control per activity wold fix it, but we probably cannot expect all activities will do the right thing.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 10 years ago by eben

Replying to tomeu:

Maybe we should have those controls in the device side of the frame. I think people right now are a bit disoriented because an activity can lower and mute the capture device and other activities cannot record any more. A control per activity wold fix it, but we probably cannot expect all activities will do the right thing.

Right, that's what I'm suggesting with the camera and mic devices. I think that's really the best solution.

I don't think the ability to set this globally should preclude the ability for activities to have their own input gain adjustments. I'm not sure I understand what you're saying about one activity preventing another from recording. The global input level should be just that; activities shouldn't have control of the master volume slider. They should only be able to adjust the gain on the signal once they get it at the master volume.

comment:7 in reply to: ↑ 6 Changed 10 years ago by tomeu

Replying to eben:

Replying to tomeu:

Maybe we should have those controls in the device side of the frame. I think people right now are a bit disoriented because an activity can lower and mute the capture device and other activities cannot record any more. A control per activity wold fix it, but we probably cannot expect all activities will do the right thing.

Right, that's what I'm suggesting with the camera and mic devices. I think that's really the best solution.

I don't think the ability to set this globally should preclude the ability for activities to have their own input gain adjustments. I'm not sure I understand what you're saying about one activity preventing another from recording. The global input level should be just that; activities shouldn't have control of the master volume slider. They should only be able to adjust the gain on the signal once they get it at the master volume.

I'm afraid in linux, apps can modify the mixer as they wish, and they seem to be already doing it, because from .uy come reports that some activity is muting the input channel and other activities stop being able to record. People is now "fixing" this by going to the terminal and running alsamixer to unmute the mic.

comment:8 Changed 10 years ago by eben

  • Bug Status changed from Unconfirmed to New

OK. That seems odd to me, but we can work with it. Let's add a "My microphone" device to the frame. This device should be a white outline when the mic is off, and XO-colored when on (it's state should match the LED on the XO hardware). If we have access to the info, it would be nice to make the secondary label of the palette indicate which activity is using the mic eg. "In use by Record". If not, we might simply state "In use" or "Not in use", to add clarity to the color states.

The secondary palette should contain a slider, just like the speaker device, which controls the master input level. It should also have a toggle, much like the speaker, which reads "Mute microphone" or "Unmute microphone".

In the future, we can have a "Show audio settings" option, and might consider making the mute state of both speaker and microphone toggle with a click on the icon itself in the Frame.

comment:9 Changed 10 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

Looks like this will miss 0.88 :(

comment:10 Changed 9 years ago by walter

  • Milestone changed from 0.88 to 0.90

comment:11 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.90 to Unspecified

comment:12 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:13 Changed 6 years ago by dnarvaez

  • Bug Status changed from Unconfirmed to New

comment:14 Changed 5 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Fixed on 0.102 we show a control in the Speaker palette.

Note: See TracTickets for help on using tickets.