Opened 12 years ago

Closed 8 years ago

Last modified 7 years ago

#799 closed defect (fixed)

easy accessible frame key on non xo-hardware

Reported by: homunq Owned by: tomeu
Priority: Normal Milestone:
Component: Sugar Version: 0.85.x
Severity: Major Keywords:
Cc: sascha_silbe, mtd Distribution/OS: Unspecified
Bug Status: New

Description

The frame should be accessible from a standard keyboard - either as an external keyboard on an XO or for sugar on a non-XO. "Insert" is a good candidate because it is generally close to the right position and is present on many netbook keyboards (a quick survey shows it present on Classmate, Asus, Dell, HP, and others; the only netbook photo I found without it was an old Casio Wince PoS which was missing the whole row of F keys, including "Esc"!)

Change History (9)

comment:1 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

Alt+Shift+F should work fine on keyboards having an Alt key. Insert is IMO a bad choice (even though it's lacking on the XO) because it's used by a lot of legacy software in a totally different sense (that is usually tightly related to its name).
I agree that we need something better than Alt+Shift+F, though. Maybe F10?
The ability to configure these shortcuts would be great, BTW. On non-standard keyboards (read smartphones and other embedded systems) the PC-style function keys are often missing, with model-specific keys instead (so just changing the hardcoded ones to something different won't help - it needs to be specifically tuned to the users device).

comment:2 Changed 12 years ago by garycmartin

No insert key on the 3 different Mac keyboards I have here... My vote is still for F5, as the next inline with the other system view keys. Using F keys from way over on the right (F10) is a little problematic as the number of F keys varies from keyboard to keyboard so can not be sure of the 'end one'. Likely need both reasonable defaults, and a control panel for customising them.

comment:3 Changed 12 years ago by mtd

  • Cc mtd added

comment:4 Changed 12 years ago by erikos

Looks like a configure option is the best idea here.

comment:5 Changed 11 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Severity changed from Unspecified to Major
  • Summary changed from Need frame key for SoaS (Insert?) to easy accessible frame key on non xo-hardware
  • Version changed from Unspecified to 0.85.x

The issue is, same to the Journal key, that on the XO F5 is hidden under the brightness keys. Maybe a configure option indeed.

comment:6 Changed 11 years ago by erikos

  • Milestone changed from Unspecified by Release Team to 0.88
  • Priority changed from Unspecified by Maintainer to Normal

Moving out to 0.88 as we are late in the cycle.

comment:7 Changed 11 years ago by garycmartin

  • Milestone changed from 0.88 to 0.90

Pushing out to 0.90, perhaps some special Sugar keys could be customisable via the new Keyboard control panel module (and stored in gconf), seems like a sane way to go (as well as making Journal more accessible from the home screen).

comment:8 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

In sugar 0.98, F5 is used to go to the Journal, and F6 to show the frame.

Reopen this ticket if needed

comment:9 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.