Opened 12 years ago

Closed 10 years ago

#751 closed enhancement (fixed)

install socks5 relay in jabber.sugarlabs.org

Reported by: tomeu Owned by: daveb
Priority: Normal Milestone: Unspecified
Component: jabber.sugarlabs.org Version: Unspecified
Severity: Unspecified Keywords:
Cc: gdesmott, bernie, alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

so file transfers with gabble are faster

Change History (6)

comment:1 Changed 12 years ago by gdesmott

SOCKS5 proxy is included in Ejabberd so all you need to do is to activate it. Look for mod_proxy65 in ejabberd.cfg IIRC.

Be aware that such proxy can be very bandwith consuming as it will be used by Gabble file transfers and stream tubes.

comment:2 Changed 10 years ago by alsroot

  • Resolution set to wontfix
  • Status changed from new to closed

Not sure that there is urgent need to speed up jabber.sl.o right now (we don't have many online users there). And since there weren't any posts here for 2 years, I'm closing this ticket. Feel free to reopen it if you think there is really need to have such proxy on jabber.sl.o

comment:3 Changed 10 years ago by alsroot

  • Component changed from infrastructure to jabber.sugarlabs.org

comment:4 Changed 10 years ago by alsroot

  • Cc alsroot added

comment:5 Changed 10 years ago by alsroot

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:6 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from reopened to closed

It seems that proxy65 is accessible on Prosdy out-of-the-box as well.
So, I enabled it as a proxy.jabber.sugarlabs.org on port 5000 on jabber.sugarlabs.org.

Feel free to reopen the ticket if it doesn't work.

Note: See TracTickets for help on using tickets.