Opened 12 years ago

Closed 9 years ago

Last modified 8 years ago

#729 closed defect (notsugar)

Browse 98 never starts, with the error "no module named hulahop"

Reported by: HoboPrimate Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: hulahop Version: Unspecified
Severity: Critical Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: New

Description

This happens in Ubuntu 9.04. I unzipped the newest Browse 98 into the Activities directory, and when I click it within Sugar, it hangs in the pulsating icon phase. Here is it's log:

"
(process:6050): Gtk-WARNING : Locale not supported by C library.

Using the fallback 'C' locale.

(sugar-activity:6050): atk-bridge-WARNING : AT_SPI_REGISTRY was not started a$

(sugar-activity:6050): atk-bridge-WARNING : IOR not set.

(sugar-activity:6050): atk-bridge-WARNING : Could not locate registry
/usr/lib/python2.6/dist-packages/sugar/util.py:25: DeprecationWarning: the sha $

import sha

Traceback (most recent call last):

File "/usr/bin/sugar-activity", line 21, in <module>

main.main()

File "/usr/lib/python2.6/dist-packages/sugar/activity/main.py", line 105, in $

module = import(module_name)

File "/home/jobezone/Activities/Browse.activity/webactivity.py", line 63, in $

import hulahop

ImportError: No module named hulahop
"

I checked and have both hulahop and python-hulahop installed.

P.S.-Is this the right trac I should be filling Sugar on a OS bugs?

Change History (9)

comment:1 Changed 12 years ago by sascha_silbe

Do you use sugar-jhbuild or the native Ubuntu packages?

comment:2 Changed 12 years ago by HoboPrimate

Native ubuntu sugar packages, and the version of python-hulahop version is 0.4.8~dfsg-3ubuntu4

comment:3 Changed 12 years ago by sascha_silbe

Looks like the Ubuntu package python-hulahop still contains Python 2.5 modules, but Python 2.6 is default in Jaunty. => upstream bug.
Not touching this bug as I'm not a Browse maintainer. My suggestion is to file an upstream bug, link to it and keep the SL one open so people know it's being worked on.

comment:4 Changed 12 years ago by HoboPrimate

I filled a skeleton of a bug to upstream/ubuntu:
https://bugs.launchpad.net/bugs/364871

comment:5 Changed 12 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from Unspecified by Release Team to 0.84

Thanks for the upstream ticket.

comment:6 Changed 12 years ago by erikos

  • Component changed from Browse to hulahop
  • Milestone changed from 0.84 to 0.86
  • Owner changed from erikos to marcopg
  • Severity changed from Unspecified to Critical

not fixed upstream yet - leaving this open.

comment:7 Changed 12 years ago by erikos

  • Owner changed from marcopg to erikos
  • Status changed from new to assigned

comment:8 Changed 9 years ago by sascha_silbe

  • Resolution set to notsugar
  • Status changed from assigned to closed

Duplicate ticket #1691 contains some additional information, though nothing really new. As #3299 points out, this still isn't fixed by Ubuntu; python-xpcom still isn't built py Ubuntu.

As it got clear that Mozilla isn't a suitable base for Browse anymore, we're moving to WebKit for Browse instead for Sugar 0.96+. This essentially means hulahop is dead, so I'm closing this ticket (as "notsugar" since it's a downstream bug).

comment:9 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.