Opened 10 years ago

Closed 5 years ago

#722 closed enhancement (fixed)

Better notification for in activity events

Reported by: erikos Owned by: eben
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: design Version: Unspecified
Severity: Major Keywords:
Cc: erikos, sascha_silbe Distribution/OS: Unspecified
Bug Status: New

Description

IRC-example: At the moment the activity icon flashes at the top right and disappears after a while. If I have not seen that I do not know that there was some activity.

I guess it would be great for example to highlight the activity icon in the frame in a certain way.

Change History (7)

comment:1 Changed 10 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:2 follow-up: Changed 10 years ago by eben

This is an important point, indeed, and critical to notifications in general (not just activity notifications). For instance, when a low battery warning appears, the battery should likewise have an indication that it has something to tell you within the Frame.

The best suggestion I have at present is some form of the usual rounded-rectangle highlight. I come to this for a number of reasons. First, we shouldn't color the entire square behind an icon, since it will appear to divide the Frame into chunks, which isn't the intent. It would also interfere with the black highlight which appears on rollover.

My first inclination was to use a gray rounded-rect outline. However, I think we should ultimately support keyboard navigation of the Frame, for which we intend to use the gray rounded-rect outline throughout the UI, which makes that a bad choice. Therefore, the best I can come up with at present is a solid white fill instead, which will keep the activity icon plainly visible, draw attention to it, differentiate it from the gray fill shown on the current selection, and leave area around it for the rollover highlight. We could also use this treatment for representing notifications in the corners as they appear to, which would ensure that the icon for the notification appeared on any color background (if they ever have transparency, as designed).

An alternative worth mentioning is the idea of badging the icon with a smaller icon indicating an alert. If we open that door, we could also support several types of badges depending on the urgency of the notification, and perhaps also open up number badges (for instance, to indicate how many messages have passed in the IRC activity since it was last focused.).

comment:3 in reply to: ↑ 2 Changed 10 years ago by garycmartin

Replying to eben:

An alternative worth mentioning is the idea of badging the icon with a smaller icon indicating an alert. If we open that door, we could also support several types of badges depending on the urgency of the notification, and perhaps also open up number badges (for instance, to indicate how many messages have passed in the IRC activity since it was last focused.).

FWIW, badges have always been my favourite each time this discussion comes up, seem to allow being more descriptive. A set of standard badges to cover the common cases could be based around primitive shapes (circle/square/triangle/octagon/star/etc), and use a frame grey outer stroke for icon separation, white fill for the base shape, and then a frame grey symbol for the message – this would avoid colour conflicts with user identity colours.

comment:4 Changed 10 years ago by erikos

About the flashing notification in the upper right corner - I guess one should be able to click on it as well to resume the activity. At least I tried that spontaneously.

comment:5 Changed 10 years ago by eben

One should be able to click on it to reveal the notification palette, as should be the case with all notifications. If desired, the palette could have a resume action in it.

comment:6 Changed 6 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

comment:7 Changed 5 years ago by godiard

  • Milestone set to Unspecified
  • Resolution set to fixed
  • Status changed from new to closed

Implemented as a feature in Sugar 0.102 http://wiki.sugarlabs.org/go/Features/Notification_System

Note: See TracTickets for help on using tickets.