Opened 10 years ago

Closed 6 years ago

#719 closed enhancement (wontfix)

Palette needs a minimum size

Reported by: erikos Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Major Keywords:
Cc: eben Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

And therefore has problems when the text gets larger (translated text). Easily seen with -s 72 and German. Before the limiting fix from yesterday the text got cropped. Now it gets ellipsized without need.

diff --git a/extensions/deviceicon/speaker.py b/extensions/deviceicon/speaker.py
index d8e7a2b..3a54464 100644
--- a/extensions/deviceicon/speaker.py
+++ b/extensions/deviceicon/speaker.py
@@ -93,8 +93,6 @@ class SpeakerPalette(Palette):
 
         self._model = model
 
-        self.set_size_request(style.zoom(style.GRID_CELL_SIZE * 4), -1)
-
         vbox = gtk.VBox()
         self.set_content(vbox)
         vbox.show()

Change History (8)

comment:1 Changed 10 years ago by erikos

  • Cc eben added

As discussed with Martin on irc, his intention was a minimum size of the palette as described in the HIG (correct eben?). Now the slider is a bit small. I guess this has to be handled in the palette class directly as we otherwise will see issues like this one.

As a fix for 0.84 I will remove the size_request.

comment:2 Changed 10 years ago by erikos

  • Milestone changed from 0.84 to 0.86
  • Severity changed from Blocker to Major
  • Summary changed from Speaker palette has fixed width to Palette needs a minimum size
  • Type changed from defect to enhancement
  • Version changed from Unspecified to 0.84.x

comment:3 Changed 10 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

Looks like this will miss 0.88 :(

comment:4 follow-up: Changed 9 years ago by walter

  • Keywords r? added

This didn't ever seem to get into the review queue... probably too late for 0.88, but leaving that milestone for the time being.

comment:5 in reply to: ↑ 4 Changed 9 years ago by tomeu

  • Keywords r? removed
  • Milestone changed from 0.88 to 0.90

Replying to walter:

This didn't ever seem to get into the review queue... probably too late for 0.88, but leaving that milestone for the time being.

That particular patch did got in, but it's only for a specific case, not for the general case.

comment:6 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.90 to Unspecified

comment:7 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:8 Changed 6 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed

I'm unconvinced we can do this in the general case. And I guess the fact that it has been here for 3 years says something.

Note: See TracTickets for help on using tickets.